summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-06-09 12:11:39 +0200
committerMartin Doege2015-06-09 12:11:39 +0200
commit6506f5ddc3c69ed10948e4b553582627a147b247 (patch)
tree4aa705573bd71d887948d9d0f1db1978a255bda4
downloadaur-6506f5ddc3c69ed10948e4b553582627a147b247.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--otf.install20
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a918a050105
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-raleway
+ pkgdesc = A sans-serif typeface
+ pkgver = 1
+ pkgrel = 1
+ url = http://theleagueofmoveabletype.com/raleway/
+ install = otf.install
+ arch = any
+ license = OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://theleagueofmoveabletype.com/raleway/download
+ md5sums = ff280d51659a149751a3fe194d2944b4
+
+pkgname = otf-raleway
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd8577a86bbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Martin Florén <martin.floren@gmail.com>
+
+pkgname=otf-raleway
+pkgver=1
+pkgrel=1
+pkgdesc="A sans-serif typeface"
+arch=('any')
+url="http://theleagueofmoveabletype.com/raleway/"
+license=('OFL')
+depends=('fontconfig' 'xorg-font-utils')
+
+install=otf.install
+source=('http://theleagueofmoveabletype.com/raleway/download')
+
+build() {
+ cd $startdir/src
+ install -Dm 644 "theleagueof-raleway-40afd9d/Raleway Thin.otf" $pkgdir/usr/share/fonts/OTF/Raleway\ Thin.otf
+}
+md5sums=('ff280d51659a149751a3fe194d2944b4')
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..52655ed5cff5
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*