summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2020-07-26 14:49:03 +0200
committermrxx2020-07-26 14:49:03 +0200
commitf1492b761fa47016e2078130d2492fb4a9741917 (patch)
treea361dacf7f4474c5dad287acc21c1c76c5b66f97
parent6d0e3a5abd452330ee650c95bc62d7d8ecf75c0d (diff)
downloadaur-f1492b761fa47016e2078130d2492fb4a9741917.tar.gz
Upgpkg: 1.052
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99d361e52725..0d44fe9fd264 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = otf-recursive
pkgdesc = A variable type family built for better code & UI
- pkgver = 1.022
+ pkgver = 1.052
pkgrel = 1
url = https://github.com/arrowtype/recursive
arch = any
license = custom:SIL Open Font License 1.1
depends = fontconfig
- depends = xorg-font-utils
- source = otf-recursive-1.022.zip::https://github.com/arrowtype/recursive/releases/download/v1.022/recursive-static_fonts-b020.zip
- source = LICENSE::https://raw.githubusercontent.com/arrowtype/recursive/master/OFL.txt
- sha1sums = c2b2956a4fcd556bad255fe2af3913dcc2ba7253
- sha1sums = f200de5d9656482b8d193adda52514b6402a3cfa
+ source = https://github.com/arrowtype/recursive/releases/download/1.052/Recursive-Beta_1.052.zip
+ sha256sums = f77299f03b77ecb01511c37bbaffa613b31234a84611a8714a172b824f4b6837
pkgname = otf-recursive
diff --git a/PKGBUILD b/PKGBUILD
index 20e9c0ea14f8..79c1aa15debf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,18 @@
# Maintainer: mrxx <mrxx at cyberhome dot at>
pkgname=otf-recursive
-pkgver=1.022
+pkgver=1.052
pkgrel=1
-_betaver=020
-_fontdir=Recursive
pkgdesc="A variable type family built for better code & UI"
arch=('any')
url="https://github.com/arrowtype/recursive"
license=('custom:SIL Open Font License 1.1')
-depends=('fontconfig' 'xorg-font-utils')
-source=("$pkgname-$pkgver.zip::${url}/releases/download/v${pkgver}/recursive-static_fonts-b${_betaver}.zip"
-"LICENSE::https://raw.githubusercontent.com/arrowtype/recursive/master/OFL.txt")
-sha1sums=('c2b2956a4fcd556bad255fe2af3913dcc2ba7253'
- 'f200de5d9656482b8d193adda52514b6402a3cfa')
-
+depends=('fontconfig')
+source=("${url}/releases/download/${pkgver}/Recursive-Beta_${pkgver}.zip")
+sha256sums=('f77299f03b77ecb01511c37bbaffa613b31234a84611a8714a172b824f4b6837')
package() {
- install -D -m644 "./LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -d ${pkgdir}/usr/share/fonts/OTF/${_fontdir}
- cd ${srcdir}/recursive-static-b1_${_betaver}
- install -Dm644 recursive_mono-static_otf/*.otf ${pkgdir}/usr/share/fonts/OTF/${_fontdir}
- install -Dm644 recursive_sans-static_otf/*.otf ${pkgdir}/usr/share/fonts/OTF/${_fontdir}
+ install -d ${pkgdir}/usr/share/fonts/OTF/Recursive
+ cp -a ${srcdir}/Recursive-Beta_${pkgver}/Recursive_Desktop/*.otc "${pkgdir}/usr/share/fonts/OTF/Recursive"
+ install -Dm644 "${srcdir}/Recursive-Beta_${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+