summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-16 13:46:42 +1200
committercaltlgin2020-08-16 13:46:42 +1200
commit5c49ee14d445b9a47cc8f17135de60c31e40caa8 (patch)
tree64ede25e3825288608786dd2d4575599fca1f474
parent883deac521f49f66e03da7d353c04a8cb5d9bbd0 (diff)
downloadaur-5c49ee14d445b9a47cc8f17135de60c31e40caa8.tar.gz
Adopt and Update PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rw-r--r--otf.install16
3 files changed, 22 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02835a92e655..1928c4d54fcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = otf-ryman-eco
- pkgdesc = The world's most beautiful sustainable font
+ pkgdesc = Environmentally sustainable typeface
pkgver = 1.0
- pkgrel = 0
- url = http://rymaneco.co.uk
- install = otf.install
+ pkgrel = 2
+ url = https://rymaneco.co.uk
arch = any
- license = custom:OFL
- depends = fontconfig
- depends = xorg-font-utils
- source = http://rymaneco.co.uk/download/ryman-eco.zip
- md5sums = faca025548b89add18d3891593f800e5
+ license = custom
+ source = ryman-eco-1.0.zip::https://rymaneco.co.uk/download/ryman-eco.zip
+ sha256sums = be47185a8ae794ce56a837aae7d7687d46b0c6fd009fde8d299829e7950caa86
pkgname = otf-ryman-eco
diff --git a/PKGBUILD b/PKGBUILD
index 69227394f166..177f13537214 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: xpt <user.xpt@gmail.com>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: xpt <user.xpt@gmail.com>
-pkgname=otf-ryman-eco
+_pkgname=ryman-eco
+pkgname="otf-${_pkgname}"
pkgver=1.0
-pkgrel=0
-pkgdesc="The world's most beautiful sustainable font"
+pkgrel=2
+pkgdesc='Environmentally sustainable typeface'
arch=('any')
-url="http://rymaneco.co.uk"
-license=('custom:OFL')
-depends=('fontconfig' 'xorg-font-utils')
-install=otf.install
-source=('http://rymaneco.co.uk/download/ryman-eco.zip')
-md5sums=('faca025548b89add18d3891593f800e5')
+url='https://rymaneco.co.uk'
+license=('custom')
+source=("${_pkgname}-${pkgver}.zip::${url}/download/${_pkgname}.zip")
+sha256sums=('be47185a8ae794ce56a837aae7d7687d46b0c6fd009fde8d299829e7950caa86')
package() {
- cd "$srcdir/Ryman Eco"
- install -d "$pkgdir/usr/share/fonts/OTF"
- install -m644 'Ryman Eco'/*.otf "$pkgdir/usr/share/fonts/OTF/"
- install -Dm644 "Ryman Eco End User License Agreement.pdf" "$pkgdir/usr/share/licenses/$pkgname/License.pdf"
+ cd "Ryman Eco"
+ install -Dm644 -t "${pkgdir}/usr/share/fonts/OTF" "Ryman Eco/RymanEco-Regular.otf"
+ install -Dm644 'Ryman EcoPoster.pdf' "${pkgdir}/usr/share/doc/${_pkgname}/poster.pdf"
+ install -Dm644 'Ryman Eco End User License Agreement.pdf' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.pdf"
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/otf.install b/otf.install
deleted file mode 100644
index 905d8c8c7702..000000000000
--- a/otf.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- echo -n "Updating font cache... "
- fc-cache -fs >/dev/null
- mkfontscale /usr/share/fonts/TTF
- mkfontdir /usr/share/fonts/TTF
- echo "done."
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
-