summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxpt2015-06-10 22:38:37 -0300
committerxpt2015-06-10 22:38:37 -0300
commit883deac521f49f66e03da7d353c04a8cb5d9bbd0 (patch)
tree31cfbe6aacd77947bc3619a52765d3fae01f03b9
downloadaur-883deac521f49f66e03da7d353c04a8cb5d9bbd0.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--otf.install16
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02835a92e655
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-ryman-eco
+ pkgdesc = The world's most beautiful sustainable font
+ pkgver = 1.0
+ pkgrel = 0
+ url = http://rymaneco.co.uk
+ install = otf.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://rymaneco.co.uk/download/ryman-eco.zip
+ md5sums = faca025548b89add18d3891593f800e5
+
+pkgname = otf-ryman-eco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69227394f166
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: xpt <user.xpt@gmail.com>
+
+pkgname=otf-ryman-eco
+pkgver=1.0
+pkgrel=0
+pkgdesc="The world's most beautiful sustainable font"
+arch=('any')
+url="http://rymaneco.co.uk"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+install=otf.install
+source=('http://rymaneco.co.uk/download/ryman-eco.zip')
+md5sums=('faca025548b89add18d3891593f800e5')
+
+package() {
+ cd "$srcdir/Ryman Eco"
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 'Ryman Eco'/*.otf "$pkgdir/usr/share/fonts/OTF/"
+ install -Dm644 "Ryman Eco End User License Agreement.pdf" "$pkgdir/usr/share/licenses/$pkgname/License.pdf"
+}
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..905d8c8c7702
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+