summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarry Beadle2019-07-25 12:23:37 +0100
committerHarry Beadle2019-07-25 12:23:37 +0100
commit8c45dd50e1ff3ca2416fd2823deddc27f44d5943 (patch)
treedb6fd3e825edc14ada309d2e9b8f000a8f388df1
downloadaur-8c45dd50e1ff3ca2416fd2823deddc27f44d5943.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac0d42a0664d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = otf-san-francisco-pro
+ pkgdesc = This sans-serif typeface is the system font for iOS, macOS, and tvOS, and includes a rounded variant. It provides a consistent, legible, and friendly typographic voice.
+ pkgver = 1
+ pkgrel = 1
+ url = https://developer.apple.com/fonts/
+ arch = any
+ license = custom
+ makedepends = p7zip
+ makedepends = dmg2img
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = https://developer.apple.com/design/downloads/SF-Font-Pro.dmg
+ md5sums = 5e8f0a64534d95db546b052c5363b273
+
+pkgname = otf-san-francisco-pro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abd92aa93dbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Harry Beadle <harrybeadle@protonmail.com>
+
+pkgname=otf-san-francisco-pro
+pkgver=1
+pkgrel=1
+pkgdesc='This sans-serif typeface is the system font for iOS, macOS, and tvOS, and includes a rounded variant. It provides a consistent, legible, and friendly typographic voice.'
+arch=('any')
+url='https://developer.apple.com/fonts/'
+license=('custom')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+makedepends=('p7zip' 'dmg2img')
+source=('https://developer.apple.com/design/downloads/SF-Font-Pro.dmg')
+md5sums=('5e8f0a64534d95db546b052c5363b273')
+
+prepare() {
+ dmg2img SF-Font-Pro.dmg SF-Font-Pro.img
+ 7z x SF-Font-Pro.img
+}
+
+package() {
+ cd 'SF-Font-Pro/San Francisco Pro/'
+ install -d -m644 "*.otf" "${pkgdir}/usr/share/fonts/apple/"
+ install -d -m644 "../San Fancisco Pro License.rtf" "${pkgdir}/usr/share/licenses/apple/"
+}
+