summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarry Beadle2019-08-28 13:13:46 +0100
committerHarry Beadle2019-08-28 13:13:46 +0100
commitb682febdfc13b452b916ec4073a95a791866d3aa (patch)
tree57386d1d752db9e4278ae37df1d4cdeed16783b4
parent09d13214d699448ed67e390c0fe6853df187a645 (diff)
downloadaur-b682febdfc13b452b916ec4073a95a791866d3aa.tar.gz
Update for new package structure.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac0d42a0664d..83c1f5e2a427 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = otf-san-francisco-pro
- pkgdesc = This sans-serif typeface is the system font for iOS, macOS, and tvOS, and includes a rounded variant. It provides a consistent, legible, and friendly typographic voice.
+ pkgdesc = System font for iOS, macOS, and tvOS.
pkgver = 1
pkgrel = 1
url = https://developer.apple.com/fonts/
@@ -7,11 +7,11 @@ pkgbase = otf-san-francisco-pro
license = custom
makedepends = p7zip
makedepends = dmg2img
- depends = fontconfig
- depends = xorg-fonts-encodings
- depends = xorg-font-utils
+ makedepends = cpio
+ makedepends = xar
+ makedepends = gzip
source = https://developer.apple.com/design/downloads/SF-Font-Pro.dmg
- md5sums = 5e8f0a64534d95db546b052c5363b273
+ md5sums = 6a2c92e8ebd3ea389d162b790423ca20
pkgname = otf-san-francisco-pro
diff --git a/PKGBUILD b/PKGBUILD
index 393a729f92a8..fd1703397afe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,24 @@
pkgname=otf-san-francisco-pro
pkgver=1
pkgrel=1
-pkgdesc='This sans-serif typeface is the system font for iOS, macOS, and tvOS, and includes a rounded variant. It provides a consistent, legible, and friendly typographic voice.'
+pkgdesc='System font for iOS, macOS, and tvOS.'
arch=('any')
url='https://developer.apple.com/fonts/'
license=('custom')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
-makedepends=('p7zip' 'dmg2img')
+makedepends=('p7zip' 'dmg2img' 'cpio' 'xar' 'gzip')
source=('https://developer.apple.com/design/downloads/SF-Font-Pro.dmg')
-md5sums=('5e8f0a64534d95db546b052c5363b273')
+md5sums=('6a2c92e8ebd3ea389d162b790423ca20')
prepare() {
dmg2img SF-Font-Pro.dmg SF-Font-Pro.img
7z x SF-Font-Pro.img
+ xar -xf "SanFranciscoPro/San Francisco Pro.pkg"
+ cat SanFranciscoPro.pkg/Payload | gunzip -dc | cpio -i
}
package() {
- cd 'SF-Font-Pro/San Francisco Pro/'
+ cd 'Library/Fonts'
install -d "${pkgdir}"/usr/share/fonts/apple/
install -m644 *.otf "${pkgdir}"/usr/share/fonts/apple/
- install -d "${pkgdir}"/usr/share/licenses/apple
- install -m644 '../San Francisco Pro Font License.rtf' "${pkgdir}"/usr/share/licenses/apple/
}