summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-05-07 13:57:58 +0100
committerJonathon Fernyhough2017-05-07 13:57:58 +0100
commitea192ef3c90ae430856689d9d1fc988b61b34170 (patch)
tree6b464fa3a8412bde0f1a968ef132a77e8edde128
downloadaur-ea192ef3c90ae430856689d9d1fc988b61b34170.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3d4d318e380
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = otf-solbera-dnd-5e-git
+ pkgdesc = A collection of unrestricted DND5e-compatible typefaces
+ pkgver = r1.92850bf
+ pkgrel = 1
+ url = https://github.com/jonathonf/solbera-dnd-fonts
+ arch = any
+ license = Custom: CC-BY-SA-4.0
+ makedepends = git
+ provides = otf-bookinsanity
+ provides = otf-mr-eaves
+ provides = otf-nodesto-caps-condensed
+ provides = otf-scaly-sans
+ provides = otf-solbera-imitation
+ provides = otf-zatanna-misdirection
+ conflicts = otf-solbera-dnd-5e
+ source = git+https://github.com/jonathonf/solbera-dnd-fonts.git
+ sha256sums = SKIP
+
+pkgname = otf-solbera-dnd-5e-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8e0539ffb6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
+pkgname=otf-solbera-dnd-5e-git
+_gitname=solbera-dnd-fonts
+pkgver=r1.92850bf
+pkgrel=1
+license=('Custom: CC-BY-SA-4.0')
+makedepends=('git')
+pkgdesc='A collection of unrestricted DND5e-compatible typefaces'
+arch=('any')
+provides=(
+ 'otf-bookinsanity'
+ 'otf-mr-eaves'
+ 'otf-nodesto-caps-condensed'
+ 'otf-scaly-sans'
+ 'otf-solbera-imitation'
+ 'otf-zatanna-misdirection'
+)
+conflicts=("${pkgname%%-git}")
+url="https://github.com/jonathonf/${_gitname}"
+source=("git+https://github.com/jonathonf/${_gitname}.git")
+sha256sums=('SKIP')
+_fontnames=(
+ 'Bookinsanity'
+ 'Mr Eaves'
+ 'Nodesto Caps Condensed'
+ 'Scaly Sans'
+ 'Solbera Imitation'
+ 'Zatanna Misdirection'
+)
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_gitname}"
+ for font in "${_fontnames[@]}"; do
+ find . -iname '*.otf' -execdir install -Dm 644 {} ${pkgdir}/usr/share/fonts/OTF/{} \;
+ done
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}