summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Kline2021-06-09 20:08:53 -0700
committerMatt Kline2021-06-09 20:23:15 -0700
commitf901bcaa5ce38b9eed93f5c8985051b7dfd3367e (patch)
tree103f22eb82a5be73825cb9f63353dfa62bb17bb3
parent5068f0940d2945fdb88f88335334be5d43f35de0 (diff)
downloadaur-f901bcaa5ce38b9eed93f5c8985051b7dfd3367e.tar.gz
STIX 2.13
Sorry for the delay.
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD14
3 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29281c821b15..6648895ecfe9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = otf-stix
pkgdesc = An OpenType font with math support, designed for scientific and engineering printing
- pkgver = 2.12
+ pkgver = 2.13
pkgrel = 1
url = http://www.stixfonts.org
arch = any
license = custom:OFL
- source = https://raw.githubusercontent.com/stipub/stixfonts/v2.12/OFL.txt
- source = https://raw.githubusercontent.com/stipub/stixfonts/v2.12/zipfiles/static_otf.zip
+ source = static_otf-2.13.zip::https://github.com/stipub/stixfonts/raw/v2.13/zipfiles/static_otf.zip
+ source = OFL-2.13.txt::https://github.com/stipub/stixfonts/raw/v2.13/OFL.txt
+ sha256sums = 58f759a766ba4fa3d4d112b190e8119afd64984aaa31d5dc273a8ce46223cc29
sha256sums = bec17cee6412788db45fd2644b301afbc99cc5d372ddd3345dc4a7bfdefb9f04
- sha256sums = c42758da2a54c77e335b80f284942e0df2ebffaffb6f6a9ff9f32ca26ae3ec23
pkgname = otf-stix
-
diff --git a/.gitignore b/.gitignore
index eb43eca5c664..9c92ffdaa46f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
pkg/
src/
-*.zip
+OFL-*.txt
+static_otf-*.zip
otf-stix-*.zst
-OFL.txt
diff --git a/PKGBUILD b/PKGBUILD
index 6fed8fa3e913..7e9015c9dc75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
pkgname=otf-stix
-pkgver=2.12
+pkgver=2.13
pkgrel=1
pkgdesc="An OpenType font with math support, designed for scientific and engineering printing"
arch=('any')
url="http://www.stixfonts.org"
license=('custom:OFL')
source=(
- "https://raw.githubusercontent.com/stipub/stixfonts/v$pkgver/OFL.txt"
- "https://raw.githubusercontent.com/stipub/stixfonts/v$pkgver/zipfiles/static_otf.zip"
+ "static_otf-$pkgver.zip::https://github.com/stipub/stixfonts/raw/v$pkgver/zipfiles/static_otf.zip"
+ "OFL-$pkgver.txt::https://github.com/stipub/stixfonts/raw/v$pkgver/OFL.txt"
)
-sha256sums=('bec17cee6412788db45fd2644b301afbc99cc5d372ddd3345dc4a7bfdefb9f04'
- 'c42758da2a54c77e335b80f284942e0df2ebffaffb6f6a9ff9f32ca26ae3ec23')
+sha256sums=('58f759a766ba4fa3d4d112b190e8119afd64984aaa31d5dc273a8ce46223cc29'
+ 'bec17cee6412788db45fd2644b301afbc99cc5d372ddd3345dc4a7bfdefb9f04')
package() {
- cd "$srcdir/"
-
install -d "$pkgdir/usr/share/fonts/OTF"
install -m644 static_otf/*.otf "$pkgdir/usr/share/fonts/OTF/"
- install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/OFL.txt"
+ install -Dm644 "OFL-$pkgver.txt" "$pkgdir/usr/share/licenses/$pkgname/OFL.txt"
}