summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasato Hashimoto2015-06-20 20:23:44 +0900
committerMasato Hashimoto2015-06-20 20:23:44 +0900
commit80dfe4061c89c84b95aaa22196d002f1af99aee3 (patch)
treee680657023e943d8042e66dc8f513d7a2253ba36
downloadaur-80dfe4061c89c84b95aaa22196d002f1af99aee3.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--otf.install15
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3227dfcc9cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-takaomj
+ pkgdesc = Japanese outline fonts based on IPAmj Fonts (otf-ipamjfont)
+ pkgver = 15.03
+ pkgrel = 1
+ url = https://launchpad.net/takao-fonts
+ install = otf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://launchpad.net/takao-fonts/trunk/15.03/+download/TakaoMjFonts_00301.01.tar.xz
+ md5sums = e86ec5915e82a67f5ae19e110a203506
+
+pkgname = otf-takaomj
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41064cfb0a14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ponsfoot <cabezon dot hashimoto at gmail dot com>
+
+pkgname=otf-takaomj
+pkgver=15.03
+pkgrel=1
+_filever=00301.01
+pkgdesc="Japanese outline fonts based on IPAmj Fonts (otf-ipamjfont)"
+arch=('any')
+url="https://launchpad.net/takao-fonts"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=otf.install
+source=(http://launchpad.net/takao-fonts/trunk/${pkgver}/+download/TakaoMjFonts_${_filever}.tar.xz)
+
+package() {
+ cd "${srcdir}/TakaoMjFonts_${_filever}"
+
+ install -d "${pkgdir}/usr/share/fonts/OTF"
+
+ install -m644 *.ttf "${pkgdir}/usr/share/fonts/OTF/"
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 IPA_Font_License_Agreement_v1.0.txt \
+ README \
+ README.ja \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+md5sums=('e86ec5915e82a67f5ae19e110a203506')
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..2158e59eac20
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}