summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Schaf2015-06-08 20:50:26 +0200
committerPhil Schaf2015-06-08 20:50:26 +0200
commit11e6ed5cf66ba270f109ee6901e8c374a9d07582 (patch)
tree957d1992ad642c0f650b945474bcdaa4499ed447
downloadaur-11e6ed5cf66ba270f109ee6901e8c374a9d07582.tar.gz
aur4 support
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
-rw-r--r--otf-texgyre-pagella-math.install11
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..289423184988
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = otf-texgyre-pagella-math
+ pkgdesc = Math companion for the TeX Gyre Pagella family
+ pkgver = 1.605
+ pkgrel = 1
+ url = http://www.gust.org.pl/projects/e-foundry/tg-math
+ install = otf-texgyre-pagella-math.install
+ arch = any
+ license = custom:GUST Font License
+ makedepends = unzip
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.gust.org.pl/projects/e-foundry/tg-math/download/texgyrepagella-math-1605.zip
+ source = http://www.gust.org.pl/projects/e-foundry/licenses/GUST-FONT-LICENSE.txt
+ md5sums = 48f1b1074f03edf0d5374cec85b96223
+ md5sums = 7ab98aedba83bca3de4a3ca3792e7390
+
+pkgname = otf-texgyre-pagella-math
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dca2a6f05b8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+pkgname=otf-texgyre-pagella-math
+pkgver=1.605
+pkgrel=1
+pkgdesc='Math companion for the TeX Gyre Pagella family'
+arch=('any')
+url='http://www.gust.org.pl/projects/e-foundry/tg-math'
+license=('custom:GUST Font License')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('unzip')
+source=(
+ "$url/download/texgyrepagella-math-${pkgver//.}.zip"
+ "http://www.gust.org.pl/projects/e-foundry/licenses/GUST-FONT-LICENSE.txt"
+)
+install="$pkgname.install"
+md5sums=('48f1b1074f03edf0d5374cec85b96223'
+ '7ab98aedba83bca3de4a3ca3792e7390')
+
+package () {
+ cd "$srcdir"
+ install -Dm644 "GUST-FONT-LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/GUST-FONT-LICENSE.txt"
+ install -Dm644 "texgyrepagella-math-${pkgver//.}/otf/texgyrepagella-math.otf" "$pkgdir/usr/share/fonts/OTF/texgyrepagella-math.otf"
+}
+
diff --git a/otf-texgyre-pagella-math.install b/otf-texgyre-pagella-math.install
new file mode 100644
index 000000000000..40597002b239
--- /dev/null
+++ b/otf-texgyre-pagella-math.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo -n 'Updating font cacheā€¦'
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo ' done'
+}
+
+post_upgrade() {
+ post_install
+}