summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeni Kunev2016-02-02 11:02:33 +0200
committerEvgeni Kunev2016-02-02 11:19:52 +0200
commit2f35b14344a707eb26902f24d981b3d31fa08002 (patch)
treef58433347f2ab7ea82f067420eef5314546736ba
downloadaur-2f35b14344a707eb26902f24d981b3d31fa08002.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rw-r--r--otf-unscii-8-alt.install15
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf0137e2de9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 09:19:51 UTC 2016
+pkgbase = otf-unscii-8-alt
+ pkgdesc = Unscii is a set of bitmapped Unicode fonts based on classic system fonts. Unscii attempts to support character cell art well while also being suitable for terminal and programming use. Based on the more peculiar glyph forms of the reference fonts.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://pelulamu.net/unscii/
+ install = otf-unscii-8-alt.install
+ arch = any
+ license = gpl
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://pelulamu.net/unscii/unscii-8-alt.otf
+ sha512sums = bfcfd61adf58b75c79bd600818d9ca9c21d9fdfeb851d849d36f8311d7bc4ec92ba0e0485256a258eca208d633a4c70a3f2cd8d6eddba00ba823931efba987e9
+
+pkgname = otf-unscii-8-alt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb99e94b4154
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Evgeni Kunev <evgeni at kunev dot me>>
+pkgname=otf-unscii-8-alt
+pkgver=1.0
+pkgrel=1
+pkgdesc="Unscii is a set of bitmapped Unicode fonts based on classic system fonts. Unscii attempts to support character cell art well while also being suitable for terminal and programming use. Based on the more peculiar glyph forms of the reference fonts."
+url="http://pelulamu.net/unscii/"
+arch=('any')
+license=('gpl')
+depends=('fontconfig' 'xorg-font-utils')
+install=$pkgname.install
+source=("http://pelulamu.net/unscii/unscii-8-alt.otf")
+sha512sums=('bfcfd61adf58b75c79bd600818d9ca9c21d9fdfeb851d849d36f8311d7bc4ec92ba0e0485256a258eca208d633a4c70a3f2cd8d6eddba00ba823931efba987e9')
+
+package() {
+ cd "${srcdir}"
+ install -Dm644 "unscii-8-alt.otf" "$pkgdir/usr/share/fonts/OTF/unscii-8-alt.otf"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/otf-unscii-8-alt.install b/otf-unscii-8-alt.install
new file mode 100644
index 000000000000..4e1a9593cef1
--- /dev/null
+++ b/otf-unscii-8-alt.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}