summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeni Kunev2016-02-02 10:58:11 +0200
committerEvgeni Kunev2016-02-02 11:19:53 +0200
commit59871e907c46123b434fa0d57434643cf8becf26 (patch)
treec03a2d48daa4772755265d1339025426c6163672
downloadaur-59871e907c46123b434fa0d57434643cf8becf26.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rw-r--r--otf-unscii-8-thin.install15
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a336ceae9999
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 09:19:52 UTC 2016
+pkgbase = otf-unscii-8-thin
+ pkgdesc = Unscii is a set of bitmapped Unicode fonts based on classic system fonts. Unscii attempts to support character cell art well while also being suitable for terminal and programming use. Based on system fonts with 1-pixel-wide lines.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://pelulamu.net/unscii/
+ install = otf-unscii-8-thin.install
+ arch = any
+ license = gpl
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://pelulamu.net/unscii/unscii-8-thin.otf
+ sha512sums = 89cfa2e806a444888002137b295d9193947376ee442db7b002e1cd29b01f4125b7c17dea22c92b327d07af25c65b58c4cf691a4129c86ff7d50c72f76c95a529
+
+pkgname = otf-unscii-8-thin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ee847af98ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Evgeni Kunev <evgeni at kunev dot me>>
+pkgname=otf-unscii-8-thin
+pkgver=1.0
+pkgrel=1
+pkgdesc="Unscii is a set of bitmapped Unicode fonts based on classic system fonts. Unscii attempts to support character cell art well while also being suitable for terminal and programming use. Based on system fonts with 1-pixel-wide lines."
+url="http://pelulamu.net/unscii/"
+arch=('any')
+license=('gpl')
+depends=('fontconfig' 'xorg-font-utils')
+install=$pkgname.install
+source=("http://pelulamu.net/unscii/unscii-8-thin.otf")
+sha512sums=('89cfa2e806a444888002137b295d9193947376ee442db7b002e1cd29b01f4125b7c17dea22c92b327d07af25c65b58c4cf691a4129c86ff7d50c72f76c95a529')
+
+package() {
+ cd "${srcdir}"
+ install -Dm644 "unscii-8-thin.otf" "$pkgdir/usr/share/fonts/OTF/unscii-8-thin.otf"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/otf-unscii-8-thin.install b/otf-unscii-8-thin.install
new file mode 100644
index 000000000000..4e1a9593cef1
--- /dev/null
+++ b/otf-unscii-8-thin.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}