summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Kline2015-12-18 22:58:17 -0800
committerMatt Kline2015-12-18 22:58:17 -0800
commit1220d1fb6afaac3cc3c4d1d98dc49f89812f3105 (patch)
tree4a38ee9dad860ef96f82e34fc931549274996241
downloadaur-1220d1fb6afaac3cc3c4d1d98dc49f89812f3105.tar.gz
Initial package
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
-rw-r--r--otf-xits.install15
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8552db379d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Dec 19 06:50:07 UTC 2015
+pkgbase = otf-xits
+ pkgdesc = An OpenType implementation of STIX fonts with math support
+ pkgver = 1.108
+ pkgrel = 1
+ url = https://github.com/khaledhosny/xits-math
+ install = otf-xits.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = https://github.com/khaledhosny/xits-math/archive/v1.108.tar.gz
+ md5sums = 6a9ff635ecc47edc0c13794f2b2a8ce1
+
+pkgname = otf-xits
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4fc7fba4335e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+v*.tar.gz
+otf-xits-*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c15cb12bd5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=otf-xits
+pkgver=1.108
+pkgrel=1
+pkgdesc="An OpenType implementation of STIX fonts with math support"
+arch=('any')
+url="https://github.com/khaledhosny/xits-math"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=otf-xits.install
+ghname=xits-math
+source=("https://github.com/khaledhosny/$ghname/archive/v$pkgver.tar.gz")
+md5sums=('6a9ff635ecc47edc0c13794f2b2a8ce1')
+
+package() {
+ cd "$srcdir/$ghname-$pkgver"
+
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 *.otf "$pkgdir/usr/share/fonts/OTF/"
+ install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/OFL.txt"
+ install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/OFL-FAQ.txt"
+}
diff --git a/otf-xits.install b/otf-xits.install
new file mode 100644
index 000000000000..2158e59eac20
--- /dev/null
+++ b/otf-xits.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}