summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkhist2019-04-30 17:51:06 +0200
committerArkhist2019-04-30 17:51:06 +0200
commit16a656b4cea17e2c21809b35cd7190d844bcdf24 (patch)
treeb661ad60fd10cdaae8e8d48e400fcccae89be345
downloadaur-16a656b4cea17e2c21809b35cd7190d844bcdf24.tar.gz
Add base release of Othellox
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0e23af2bab9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = othellox
+ pkgdesc = Reversi game in C allowing AI-vs-AI automation
+ pkgver = 0_1
+ pkgrel = 1
+ url = https://framagit.org/Arkhist/othellox
+ arch = any
+ license = MIT
+ makedepends = clang
+ depends = ncurses
+ source = https://framagit.org/Arkhist/othellox/-/archive/master/othellox-master.zip
+ sha256sums = 24d34055f1d8f6468b467ea05a860fcf547735cc7aaf414825afe18031219278
+
+pkgname = othellox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2958ba5bb831
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Peyrille Benjamin <peyrille.benjamin@gmail.com>
+# Contributor : Rogalle Quentin <quentin.rogalle@etudiant.univ-perp.fr>
+pkgname=othellox
+pkgver=0_1
+pkgrel=1
+pkgdesc="Reversi game in C allowing AI-vs-AI automation"
+arch=('any')
+url="https://framagit.org/Arkhist/othellox"
+license=('MIT')
+depends=('ncurses')
+makedepends=('clang')
+source=("https://framagit.org/Arkhist/othellox/-/archive/master/othellox-master.zip")
+sha256sums=('24d34055f1d8f6468b467ea05a860fcf547735cc7aaf414825afe18031219278')
+
+prepare() {
+ cd "${pkgname}-master"
+}
+
+build() {
+ cd "${pkgname}-master"
+ cd othellogame
+ make
+}
+
+check() {
+ cd "${pkgname}-master"
+}
+
+package() {
+ cd "$pkgname-master"
+ cd othellogame
+ install -Dm755 othellox "${pkgdir}/usr/bin/othellox"
+ install -Dm655 include/board.h "${pkgdir}/usr/include/othellox/board.h"
+ install -Dm655 include/ai/ai_api.h "${pkgdir}/usr/include/othellox/ai_api.h"
+ install -Dm655 include/gameState.h "${pkgdir}/usr/include/othellox/gameState.h"
+ install -Dm655 basic-ai "${pkgdir}/usr/share/othellox/basic-ai"
+ install -Dm655 ordinatrice-ai "${pkgdir}/usr/share/othellox/ordinatrice-ai"
+}