summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkhist2019-05-04 20:10:03 +0200
committerArkhist2019-05-04 20:10:03 +0200
commit8e6ef6ad6c38c876d2cab80d112ac4aa5e588deb (patch)
tree1c47392c4e3eddcf3f74cb2f0c2442f733c0190d
parentafb6fa4b66473eb646cf2ce9a32ed6b8efa51e32 (diff)
downloadaur-8e6ef6ad6c38c876d2cab80d112ac4aa5e588deb.tar.gz
Full Othellox Release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3a8069e8128..2bbd16ee6f87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = othellox
pkgdesc = Reversi game in C allowing AI-vs-AI automation
- pkgver = 0_3
- pkgrel = 2
+ pkgver = 1_0
+ pkgrel = 1
url = https://framagit.org/Arkhist/othellox
arch = any
license = MIT
makedepends = clang
depends = ncurses
source = https://framagit.org/Arkhist/othellox/-/archive/master/othellox-master.zip
- sha256sums = 60e6f253c581b37f57b97a25c0127abea310aa18ae0eed8181623577fe97acd8
+ sha256sums = 28c36d80975ee1337052f2b5a4f1252eb54c2939a27ef1d5628ff423887b41a1
pkgname = othellox
diff --git a/PKGBUILD b/PKGBUILD
index 8c5d28ee5085..122b9f8fa7df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Peyrille Benjamin <peyrille.benjamin@gmail.com>
# Contributor : Rogalle Quentin <quentin.rogalle@etudiant.univ-perp.fr>
pkgname=othellox
-pkgver=0_3
-pkgrel=2
+pkgver=1_0
+pkgrel=1
pkgdesc="Reversi game in C allowing AI-vs-AI automation"
arch=('any')
url="https://framagit.org/Arkhist/othellox"
@@ -10,7 +10,7 @@ license=('MIT')
depends=('ncurses')
makedepends=('clang')
source=("https://framagit.org/Arkhist/othellox/-/archive/master/othellox-master.zip")
-sha256sums=('60e6f253c581b37f57b97a25c0127abea310aa18ae0eed8181623577fe97acd8')
+sha256sums=('28c36d80975ee1337052f2b5a4f1252eb54c2939a27ef1d5628ff423887b41a1')
prepare() {
cd "${pkgname}-master"
@@ -19,7 +19,7 @@ prepare() {
build() {
cd "${pkgname}-master"
cd othellogame
- make
+ make ARCHLINUX=yes
}
check() {
@@ -35,4 +35,8 @@ package() {
install -Dm655 include/gameState.h "${pkgdir}/usr/include/othellox/gameState.h"
install -Dm655 basic-ai "${pkgdir}/usr/share/othellox/basic-ai"
install -Dm655 ordinatrice-ai "${pkgdir}/usr/share/othellox/ordinatrice-ai"
+ install -Dm655 radiation-ai "${pkgdir}/usr/share/othellox/radiation-ai"
+ install -Dm655 scanner-ai "${pkgdir}/usr/share/othellox/scanner-ai"
+ install -Dm655 xray-ai "${pkgdir}/usr/share/othellox/xray-ai"
+ install -Dm655 oracle-ai "${pkgdir}/usr/share/othellox/oracle-ai"
}