summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlyess Bachiri2021-01-02 19:19:59 -0500
committerIlyess Bachiri2021-01-02 19:19:59 -0500
commit86902c71df655ea4ad043e3b95f72cb05c898aa1 (patch)
tree8970583ecbfd0607bac4de35681851374168b2ce
downloadaur-86902c71df655ea4ad043e3b95f72cb05c898aa1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..676f64dba5b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otoclone
+ pkgdesc = Automatic backup utility
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/bilyes/otoclone
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ depends = rclone
+ depends = inotify-tools
+ source = git+https://github.com/bilyes/otoclone
+ md5sums = SKIP
+
+pkgname = otoclone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89e4a783315a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Ilyess Bachiri <ae767c5e-13d3-460e-8b0e-03929616d9ad@anonaddy.me>
+pkgname=otoclone
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Automatic backup utility"
+arch=("x86_64")
+url="https://github.com/bilyes/otoclone"
+license=('MIT')
+depends=(rclone inotify-tools)
+makedepends=(git go)
+source=("git+$url")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ go build -o "$pkgname"
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/local/bin
+ cd "$pkgname"
+ install -Dm755 "$pkgname" "$pkgdir"/usr/local/bin/"$pkgname"
+}