summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2018-02-03 17:43:40 +1100
committerStephen Gregoratto2018-02-03 17:52:17 +1100
commit78b7ccc8370e645164b552bede88f12156e773ec (patch)
tree7812d91ba6a1be7586c3e9a133e2870aebe0ff2a
parent499d14220bf180a16819b6a9071f33889d1d9d23 (diff)
downloadaur-78b7ccc8370e645164b552bede88f12156e773ec.tar.gz
Update to v1.1.0, replace json-glib w/ jansson
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a033d52e12a..12896537bfa1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = otpclient
pkgdesc = Simple GTK+ v3 TOTP/HOTP client that uses libcotp
- pkgver = 1.0.6
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/paolostivanin/OTPClient
arch = x86_64
@@ -9,15 +9,14 @@ pkgbase = otpclient
makedepends = git
depends = gtk3
depends = glib2
- depends = json-glib
+ depends = jansson
depends = libgcrypt
- depends = json-glib
depends = libzip
depends = libcotp
depends = pkg-config
- provides = otpclient
- source = https://github.com/paolostivanin/OTPClient/archive/v1.0.6.tar.gz
- sha256sums = 1f213de12d09c512944a2d13550e9e2439cbe638302b7eb54c75f93bb3451e07
+ conflicts = otpclient
+ source = https://github.com/paolostivanin/OTPClient/archive/v1.1.0.tar.gz
+ sha256sums = cf93aa21db03e821bd987e4471e1f35fae5c846cc8482249c589ba51969cdc30
pkgname = otpclient
diff --git a/PKGBUILD b/PKGBUILD
index 385c0ad6ad98..b9fe06f1982c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgname=otpclient
_dirname=OTPClient
-pkgver=1.0.6
+pkgver=1.1.0
pkgrel=1
pkgdesc="Simple GTK+ v3 TOTP/HOTP client that uses libcotp"
arch=('x86_64')
url="https://github.com/paolostivanin/OTPClient"
license=('GPL3')
-depends=('gtk3' 'glib2' 'json-glib' 'libgcrypt' 'json-glib' 'libzip' 'libcotp' 'pkg-config')
+depends=('gtk3' 'glib2' 'jansson' 'libgcrypt' 'libzip' 'libcotp' 'pkg-config')
makedepends=('cmake' 'git')
conflicts=(otpclient)
source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('1f213de12d09c512944a2d13550e9e2439cbe638302b7eb54c75f93bb3451e07')
+sha256sums=('cf93aa21db03e821bd987e4471e1f35fae5c846cc8482249c589ba51969cdc30')
build() {
cd $_dirname-$pkgver