summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-04 14:32:25 -0600
committerLuis Martinez2022-01-04 14:32:25 -0600
commitde5256a683307e673413eb084f57a4a99ae4d1e6 (patch)
treec3a5bf605c7be688d0fd87d4b7850fb1dab19a2b
parent474f12f78468a47d18e0ef97108c278bb01a2496 (diff)
downloadaur-otpclient-git.tar.gz
package cleanup
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73bd2e3207d9..ee61ecc3a604 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = otpclient-git
- pkgdesc = A simple GTK+ v3 TOTP/HOTP client
- pkgver = v1.2.0.r4.3ca48f2
+ pkgdesc = GTK+ v3 TOTP/HOTP client
+ pkgver = 2.4.7.r2.gf930e38
pkgrel = 1
url = https://github.com/paolostivanin/OTPClient
arch = x86_64
@@ -15,9 +15,11 @@ pkgbase = otpclient-git
depends = libcotp
depends = libpng
depends = zbar
+ provides = otpclient
conflicts = otpclient
- source = git+https://github.com/paolostivanin/OTPClient
+ source = otpclient-git::git+https://github.com/paolostivanin/OTPClient?signed
+ validpgpkeys = 060C6B7D3869F148C4C4ACD43C9BE9B64EC1EA64
+ validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
sha256sums = SKIP
pkgname = otpclient-git
-
diff --git a/PKGBUILD b/PKGBUILD
index edde5ee3f859..85194a84a4bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,37 @@
-# Maintainer: KingofToasters <themanhimself at sgregoratto dot me>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: KingofToasters <themanhimself at sgregoratto dot me>
pkgname=otpclient-git
-_dirname=OTPClient
-pkgver=v1.2.0.r4.3ca48f2
+pkgver=2.4.7.r2.gf930e38
pkgrel=1
-pkgdesc="A simple GTK+ v3 TOTP/HOTP client"
+pkgdesc="GTK+ v3 TOTP/HOTP client"
arch=('x86_64')
url="https://github.com/paolostivanin/OTPClient"
license=('GPL3')
depends=('gtk3' 'glib2' 'jansson' 'libgcrypt' 'libzip' 'libcotp' 'libpng' 'zbar')
makedepends=('cmake' 'git')
-conflicts=(otpclient)
-source=("git+$url")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url?signed")
sha256sums=('SKIP')
+validpgpkeys=(
+ '060C6B7D3869F148C4C4ACD43C9BE9B64EC1EA64' ## Paolo Stivanin
+ '5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23') ## GitHub
pkgver() {
- cd "$_dirname"
- git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
build() {
- cmake "$_dirname"/ -DCMAKE_INSTALL_PREFIX:PATH=/usr
- make
+ cmake \
+ -B build \
+ -S "$pkgname" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ make -C build
}
package() {
- make DESTDIR="$pkgdir/" install
+ make -C build DESTDIR="$pkgdir/" install
}