summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgcurse2018-04-09 14:35:18 +0200
committergcurse2018-04-09 14:35:18 +0200
commit46be65cfb063c490e31a77db944bab5a2b40dcf8 (patch)
tree3617f2ad47751984f2f7174c26b0f1c6819ce782
downloadaur-46be65cfb063c490e31a77db944bab5a2b40dcf8.tar.gz
Initial commit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD32
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f112f51d8f4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = otr-verwaltung2p-git
+ pkgdesc = Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.
+ pkgver = 0.9.7
+ pkgrel = 1
+ url = https://www.otrforum.com/showthread.php?67612-OTR-Verwaltung-durch-Patches-erweiterte-OTR-Verwaltung-Betatest
+ arch = any
+ license = GPL3
+ makedepends = python2-distutils-extra
+ depends = pygtk
+ depends = python2-xdg
+ depends = python2-dbus
+ depends = python2-simplejson
+ depends = libtorrent-rasterbar
+ depends = gstreamer0.10
+ depends = gstreamer0.10-base-plugins
+ depends = gstreamer0.10-good-plugins
+ depends = gstreamer0.10-ugly-plugins
+ depends = gstreamer0.10-gnonlin
+ depends = gstreamer0.10-ffmpeg
+ depends = gstreamer0.10-python
+ depends = mplayer
+ depends = aria2
+ depends = wget
+ optdepends = avidemux-cli: If you do NOT want to use Smartmkvmerge for divx (not recommended)
+ optdepends = avidemux-qt: If you do NOT want to use the internal Cutinterface (not recommended)
+ optdepends = wine: If you want to use virtualdub (only needed for old recordings (2011 and earlier))
+ optdepends = mediainfo-gui: For mediainfo-gui
+ source = git+https://github.com/monarc99/otr-verwaltung.git#branch=master
+ sha256sums = SKIP
+
+pkgname = otr-verwaltung2p-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63f78e89999b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: gCurse <gcurse at web de>
+
+pkgname='otr-verwaltung2p-git'
+pkgver='0.9.7'
+pkgrel='1'
+pkgdesc='Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.'
+arch=('any')
+url='https://www.otrforum.com/showthread.php?67612-OTR-Verwaltung-durch-Patches-erweiterte-OTR-Verwaltung-Betatest'
+license=('GPL3')
+depends=('pygtk' 'python2-xdg' 'python2-dbus' 'python2-simplejson' 'libtorrent-rasterbar'
+ 'gstreamer0.10' 'gstreamer0.10-base-plugins' 'gstreamer0.10-good-plugins'
+ 'gstreamer0.10-ugly-plugins' 'gstreamer0.10-gnonlin' 'gstreamer0.10-ffmpeg'
+ 'gstreamer0.10-python' 'mplayer' 'aria2' 'wget')
+optdepends=('avidemux-cli: If you do NOT want to use Smartmkvmerge for divx (not recommended)'
+ 'avidemux-qt: If you do NOT want to use the internal Cutinterface (not recommended)'
+ 'wine: If you want to use virtualdub (only needed for old recordings (2011 and earlier))'
+ 'mediainfo-gui: For mediainfo-gui')
+makedepends=('python2-distutils-extra')
+
+source=("git+https://github.com/monarc99/otr-verwaltung.git#branch=master")
+sha256sums=('SKIP')
+_gitname='otr-verwaltung'
+
+pkgver() {
+ cd ${_gitname}
+ cat data/VERSION
+}
+
+package() {
+ cd ${_gitname}
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}