summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgcurse2020-02-03 17:07:45 +0100
committergcurse2020-02-03 17:07:45 +0100
commit84423a65d78a01292412b5622d990ebe7034d9f4 (patch)
tree885b34fc2e6acc42306cbe95fbbd01c6b4b0044c
downloadaur-84423a65d78a01292412b5622d990ebe7034d9f4.tar.gz
Update Mo 2020-02-03_170745
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD35
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..865d4d096a88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = otr-verwaltung3p-dev-git
+ pkgdesc = Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/EinApfelBaum/otr-verwaltung3p
+ arch = any
+ license = GPL3
+ makedepends = python-distutils-extra
+ depends = gtk3
+ depends = python
+ depends = python-gobject
+ depends = gst-python
+ depends = python-xdg
+ depends = python-dbus
+ depends = python-cairo
+ depends = python-requests
+ depends = python-keyring
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = gst-libav
+ depends = mpv
+ depends = ffmpeg
+ depends = ffms2
+ depends = mediainfo
+ depends = mkvtoolnix-cli
+ optdepends = gnome-keyring: For password storing in keyring
+ optdepends = kwallet: For password storing in wallet
+ optdepends = mediainfo-gui: For plugin Mediainfo
+ optdepends = otr-verwaltung3p-vdub: For cutting old OTR files
+ provides = otr-verwaltung3p
+ conflicts = otr-verwaltung3p
+ options = !strip
+ source = git+https://github.com/EinApfelBaum/otr-verwaltung3p.git#branch=development
+ sha256sums = SKIP
+
+pkgname = otr-verwaltung3p-dev-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a3f04b4a142
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: gCurse <gcurse at web de>
+
+pkgname=otr-verwaltung3p-dev-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc='Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.'
+arch=('any')
+url='https://github.com/EinApfelBaum/otr-verwaltung3p'
+license=('GPL3')
+depends=('gtk3' 'python' 'python-gobject' 'gst-python' 'python-xdg' 'python-dbus' 'python-cairo'
+ 'python-requests' 'python-keyring' 'gst-plugins-base' 'gst-plugins-good'
+ 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'mpv' 'ffmpeg' 'ffms2' 'mediainfo'
+ 'mkvtoolnix-cli')
+optdepends=('gnome-keyring: For password storing in keyring'
+ 'kwallet: For password storing in wallet'
+ 'mediainfo-gui: For plugin Mediainfo'
+ 'otr-verwaltung3p-vdub: For cutting old OTR files')
+makedepends=('python-distutils-extra')
+conflicts=('otr-verwaltung3p')
+provides=('otr-verwaltung3p')
+source=("git+https://github.com/EinApfelBaum/otr-verwaltung3p.git#branch=development")
+sha256sums=('SKIP')
+options=('!strip')
+
+_gitname='otr-verwaltung3p'
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
+}