summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Schury2015-10-28 16:59:55 +0100
committerDavid Schury2015-10-28 17:01:32 +0100
commit2e9b9075941c4ef97b911109e1458b82bac73161 (patch)
treebd6b7b1928b01432b25af203699f7d3e4cf35866
downloadaur-2e9b9075941c4ef97b911109e1458b82bac73161.tar.gz
Initial import.
Used patches affects the installation process of the makefile. The first issue, which will be fixed by destdir.patch is, that it is not possible to install files in another directory, than specified in PREFIX. The second issue, which is fixed by mkdir.patch is, that the Makefile doesn't ensure that the installation destination exists.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--destdir.patch14
-rw-r--r--mkdir.patch12
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfc076e9e0c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Oct 28 15:59:38 UTC 2015
+pkgbase = otrtool-git
+ pkgdesc = Open source decoder for .otrkey files (onlinetvrecorder.com)
+ pkgver = 1.1.0.16.g2feb58d
+ pkgrel = 1
+ url = https://github.com/otrtool/otrtool
+ arch = any
+ license = custom:CC0
+ makedepends = git
+ depends = curl
+ depends = libmcrypt
+ provides = otrtool
+ source = git+https://github.com/otrtool/otrtool.git
+ source = destdir.patch
+ source = mkdir.patch
+ md5sums = SKIP
+ md5sums = fe06c0ed4ea003fae2cf2f0391f04a32
+ md5sums = 6917038171b9aa27f3a574ec5c9f8646
+
+pkgname = otrtool-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb67b1ffa25e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: David Schury <dasc@posteo.de>
+
+pkgname=otrtool-git
+_pkgname=otrtool
+pkgver=1.1.0.16.g2feb58d
+pkgrel=1
+pkgdesc="Open source decoder for .otrkey files (onlinetvrecorder.com)"
+arch=('any')
+url="https://github.com/otrtool/otrtool"
+license=('custom:CC0')
+depends=('curl' 'libmcrypt')
+makedepends=('git')
+conficts=('otrtool')
+provides=('otrtool')
+source=("git+https://github.com/$_pkgname/$_pkgname.git"
+ "destdir.patch"
+ "mkdir.patch")
+md5sums=('SKIP'
+ 'fe06c0ed4ea003fae2cf2f0391f04a32'
+ '6917038171b9aa27f3a574ec5c9f8646')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags | sed -e 's|-|.|g' -e 's|^v||'
+}
+
+prepare() {
+ cd "$_pkgname"
+ patch -Np1 -i "../destdir.patch"
+ patch -Np1 -i "../mkdir.patch"
+}
+
+build() {
+ cd "$_pkgname"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$_pkgname"
+ make PREFIX=/usr DESTDIR=$pkgdir install
+}
+
diff --git a/destdir.patch b/destdir.patch
new file mode 100644
index 000000000000..a6b5727a45fb
--- /dev/null
+++ b/destdir.patch
@@ -0,0 +1,14 @@
+diff -aur otrtool.orig/Makefile otrtool/Makefile
+--- otrtool.orig/Makefile 2015-10-28 16:53:31.491505911 +0100
++++ otrtool/Makefile 2015-10-28 16:53:55.227888625 +0100
+@@ -52,8 +52,8 @@
+ $(RM) $(OBJS) $(MAIN) $(MAIN).1.gz
+
+ install: $(MAIN) $(MAIN).1.gz
+- install -m 0755 $(MAIN) $(PREFIX)/bin
+- install -m 0644 $(MAIN).1.gz $(PREFIX)/share/man/man1
++ install -m 0755 $(MAIN) $(DESTDIR)$(PREFIX)/bin
++ install -m 0644 $(MAIN).1.gz $(DESTDIR)$(PREFIX)/share/man/man1
+
+ depend: $(SRCS)
+ makedepend -w70 -Y $^
diff --git a/mkdir.patch b/mkdir.patch
new file mode 100644
index 000000000000..a081a44f8354
--- /dev/null
+++ b/mkdir.patch
@@ -0,0 +1,12 @@
+diff -aur otrtool.orig/Makefile otrtool/Makefile
+--- otrtool.orig/Makefile 2015-10-28 16:57:39.761881708 +0100
++++ otrtool/Makefile 2015-10-28 16:58:09.018201634 +0100
+@@ -52,6 +52,8 @@
+ $(RM) $(OBJS) $(MAIN) $(MAIN).1.gz
+
+ install: $(MAIN) $(MAIN).1.gz
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
+ install -m 0755 $(MAIN) $(DESTDIR)$(PREFIX)/bin
+ install -m 0644 $(MAIN).1.gz $(DESTDIR)$(PREFIX)/share/man/man1
+