summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-05-13 23:10:39 +0300
committerAdrian Perez de Castro2020-05-13 23:10:39 +0300
commit1bff47ff831e8248a53d0097014f86370443cfc2 (patch)
treefa3e3a705ce99423c9b1311ec3b6a243d3a36709
parent8a8b36213c5ff57edc2f6e98f7269868ec08ad98 (diff)
downloadaur-1bff47ff831e8248a53d0097014f86370443cfc2.tar.gz
Bump to version 8.0.0
Update to version 8.0.0, update "no-test.patch", and drop the "-Dvariations=true” option (no longer supported).
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--no-tests.patch12
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3810fd98ed2..209d6604dba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ots
pkgdesc = OpenType fonts sanitiser. Supports TTF, WOFF, WOFF2 and other formats
- pkgver = 7.1.9
+ pkgver = 8.0.0
pkgrel = 1
url = https://github.com/khaledhosny/ots
arch = i686
@@ -10,10 +10,10 @@ pkgbase = ots
makedepends = ninja
depends = freetype2
conflicts = ots-git
- source = https://github.com/khaledhosny/ots/releases/download/v7.1.9/ots-7.1.9.tar.xz
+ source = https://github.com/khaledhosny/ots/releases/download/v8.0.0/ots-8.0.0.tar.xz
source = no-tests.patch
- sha512sums = 0defa5b9d03ab76f8d5a9403d0dd6a285b42def6151bad4c1cc2baed95e7d5feeb22c79fec313644de84a015d2fa38d8bf5eabcf9ce43a96652278aeeec5f246
- sha512sums = 5cbbe4d68f83505892a7e04f8a8d8f541a982b43a47839dd6320912961c3c6178874ca3c488c26333d02e64bbef7235b623a59722f6cd38b4b9e6ae5a4858aba
+ sha512sums = efe6f67e27856657e93ea6c678da83d4e5fd600d48408a2981933855cc4ee38f118b308a896000285a3c2fc123a64e414a9f05cf73db72401567b0bb916d3cad
+ sha512sums = f061a37a8e940ca55489f308f3850a3a8a7e8ab04d7af600bef6645ae49586406eb3dd213f136236e8eec7c0384748a7f5ec8852e000ca45f99699dd974d21bb
pkgname = ots
diff --git a/PKGBUILD b/PKGBUILD
index 1f74658d9dc7..395c7b9bbc4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgname=ots
-pkgver=7.1.9
+pkgver=8.0.0
pkgrel=1
pkgdesc='OpenType fonts sanitiser. Supports TTF, WOFF, WOFF2 and other formats'
arch=(i686 x86_64)
@@ -10,8 +10,8 @@ depends=(freetype2)
makedepends=(meson ninja)
conflicts=(ots-git)
source=("${url}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz" no-tests.patch)
-sha512sums=('0defa5b9d03ab76f8d5a9403d0dd6a285b42def6151bad4c1cc2baed95e7d5feeb22c79fec313644de84a015d2fa38d8bf5eabcf9ce43a96652278aeeec5f246'
- '5cbbe4d68f83505892a7e04f8a8d8f541a982b43a47839dd6320912961c3c6178874ca3c488c26333d02e64bbef7235b623a59722f6cd38b4b9e6ae5a4858aba')
+sha512sums=('efe6f67e27856657e93ea6c678da83d4e5fd600d48408a2981933855cc4ee38f118b308a896000285a3c2fc123a64e414a9f05cf73db72401567b0bb916d3cad'
+ 'f061a37a8e940ca55489f308f3850a3a8a7e8ab04d7af600bef6645ae49586406eb3dd213f136236e8eec7c0384748a7f5ec8852e000ca45f99699dd974d21bb')
prepare () {
cd "${pkgname}-${pkgver}"
@@ -21,7 +21,7 @@ prepare () {
build() {
cd "${pkgname}-${pkgver}"
rm -rf build
- arch-meson build -Dgraphite=true -Dvariations=true
+ arch-meson build -Dgraphite=true
ninja -C build
}
diff --git a/no-tests.patch b/no-tests.patch
index a1b6c9b8d03f..bd09fc404dae 100644
--- a/no-tests.patch
+++ b/no-tests.patch
@@ -1,6 +1,6 @@
---- meson.build.orig 2019-05-19 01:25:08.696623185 +0300
-+++ meson.build 2019-05-19 01:26:51.054299530 +0300
-@@ -26,8 +26,7 @@
+--- meson.build.orig 2020-05-13 22:49:48.733998032 +0300
++++ meson.build 2020-05-13 22:53:10.325320288 +0300
+@@ -22,8 +22,7 @@
conf.set('HAVE_FREETYPE', 1)
endif
@@ -34,14 +34,14 @@
-
-gtest = dependency('gtest', fallback: ['gtest', 'gtest_main_dep'])
-
--cff_type2_charstring = executable('cff_type2_charstring',
-- 'tests/cff_type2_charstring_test.cc',
+-cff_charstring = executable('cff_charstring',
+- 'tests/cff_charstring_test.cc',
- include_directories: include_directories(['include', 'src']),
- link_with: libots,
- dependencies: gtest,
-)
-
--test('cff_type2_charstring', cff_type2_charstring)
+-test('cff_charstring', cff_charstring)
-
-
-layout_common_table = executable('layout_common_table',