summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-11-11 21:29:30 +0200
committerAdrian Perez de Castro2020-11-11 21:29:30 +0200
commitff1421dce66ac16fbdeaccc9d2d276a4cecbc758 (patch)
treee341905176cfd20baea855e45fdef9cbbc4825c2
parent95cb7f67753bcb6c2312c5a1be6ac1c8b07f4707 (diff)
downloadaur-ff1421dce66ac16fbdeaccc9d2d276a4cecbc758.tar.gz
Bump to version 8.1.0
Also enable running the tests at build time with a small patch to make Meson use the system-installed gtest library instead of letting it try to download it.
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD18
-rw-r--r--no-tests.patch73
-rw-r--r--use-system-gtest.patch11
5 files changed, 34 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d64be97713b..66d979ba5187 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = ots
pkgdesc = OpenType fonts sanitiser. Supports TTF, WOFF, WOFF2 and other formats
- pkgver = 8.0.0
- pkgrel = 2
+ pkgver = 8.1.0
+ pkgrel = 1
url = https://github.com/khaledhosny/ots
arch = x86_64
arch = i686
license = custom
makedepends = meson
makedepends = ninja
+ makedepends = gtest
depends = freetype2
depends = libfreetype.so
- source = https://github.com/khaledhosny/ots/releases/download/v8.0.0/ots-8.0.0.tar.xz
- source = no-tests.patch
- sha512sums = efe6f67e27856657e93ea6c678da83d4e5fd600d48408a2981933855cc4ee38f118b308a896000285a3c2fc123a64e414a9f05cf73db72401567b0bb916d3cad
- sha512sums = f061a37a8e940ca55489f308f3850a3a8a7e8ab04d7af600bef6645ae49586406eb3dd213f136236e8eec7c0384748a7f5ec8852e000ca45f99699dd974d21bb
+ source = https://github.com/khaledhosny/ots/releases/download/v8.1.0/ots-8.1.0.tar.xz
+ source = use-system-gtest.patch
+ sha512sums = 5fe002c7e4351737cdb86e5288e8ab9a2076cdb25f92193e406ecf4f606daaaa2f7a632c005c3dda2e5385b2e66d4df7321cc6b126f1ec08e616d098a6a0f642
+ sha512sums = a8e06db16a17f0c2851628cc970b828a2c6df786ed553381906e80f286e2651fd56acf3253156041850a1aeedcaeaf20840db738cf96e0e1582176dbdf3300f2
pkgname = ots
diff --git a/.gitignore b/.gitignore
index 8474eb64af22..c0caf0f11143 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
-/*.log
-/*.tar
-/*.tar.*
-/pkg/
-/src/
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
+!/use-system-gtest.patch
diff --git a/PKGBUILD b/PKGBUILD
index 196548d94fe2..207bcc952388 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=ots
-pkgver=8.0.0
-pkgrel=2
+pkgver=8.1.0
+pkgrel=1
pkgdesc='OpenType fonts sanitiser. Supports TTF, WOFF, WOFF2 and other formats'
arch=(x86_64 i686)
url=https://github.com/khaledhosny/ots
license=(custom)
depends=(freetype2 libfreetype.so)
-makedepends=(meson ninja)
+makedepends=(meson ninja gtest)
source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz"
- no-tests.patch)
-sha512sums=('efe6f67e27856657e93ea6c678da83d4e5fd600d48408a2981933855cc4ee38f118b308a896000285a3c2fc123a64e414a9f05cf73db72401567b0bb916d3cad'
- 'f061a37a8e940ca55489f308f3850a3a8a7e8ab04d7af600bef6645ae49586406eb3dd213f136236e8eec7c0384748a7f5ec8852e000ca45f99699dd974d21bb')
+ use-system-gtest.patch)
+sha512sums=('5fe002c7e4351737cdb86e5288e8ab9a2076cdb25f92193e406ecf4f606daaaa2f7a632c005c3dda2e5385b2e66d4df7321cc6b126f1ec08e616d098a6a0f642'
+ 'a8e06db16a17f0c2851628cc970b828a2c6df786ed553381906e80f286e2651fd56acf3253156041850a1aeedcaeaf20840db738cf96e0e1582176dbdf3300f2')
prepare () {
cd "$pkgname-$pkgver"
- patch -p0 < "$srcdir/no-tests.patch"
+ patch -p0 < "$srcdir/use-system-gtest.patch"
}
build() {
@@ -26,6 +26,10 @@ build() {
ninja -C build
}
+check () {
+ meson test -C "$pkgname-$pkgver/build"
+}
+
package() {
cd "$pkgname-$pkgver"
DESTDIR="$pkgdir" ninja -C build install
diff --git a/no-tests.patch b/no-tests.patch
deleted file mode 100644
index bd09fc404dae..000000000000
--- a/no-tests.patch
+++ /dev/null
@@ -1,73 +0,0 @@
---- meson.build.orig 2020-05-13 22:49:48.733998032 +0300
-+++ meson.build 2020-05-13 22:53:10.325320288 +0300
-@@ -22,8 +22,7 @@
- conf.set('HAVE_FREETYPE', 1)
- endif
-
--coretext = dependency('appleframeworks', modules: 'applicationservices',
-- required: false)
-+coretext = disabler()
- if coretext.found()
- conf.set('HAVE_CORETEXT', 1)
- endif
-@@ -242,15 +241,6 @@
- dependencies: deps,
- install: true,
- )
-- test_good_fonts = find_program('tests/test_good_fonts.sh')
-- test('test_good_fonts',
-- test_good_fonts,
-- timeout: 9999,
-- env: [
-- 'top_srcdir=@0@'.format(meson.current_source_dir()),
-- 'top_builddir=@0@'.format(meson.current_build_dir()),
-- ]
-- )
- endif
-
-
-@@ -288,44 +278,3 @@
- install: true,
- )
- endif
--
--
--gtest = dependency('gtest', fallback: ['gtest', 'gtest_main_dep'])
--
--cff_charstring = executable('cff_charstring',
-- 'tests/cff_charstring_test.cc',
-- include_directories: include_directories(['include', 'src']),
-- link_with: libots,
-- dependencies: gtest,
--)
--
--test('cff_charstring', cff_charstring)
--
--
--layout_common_table = executable('layout_common_table',
-- 'tests/layout_common_table_test.cc',
-- include_directories: include_directories(['include', 'src']),
-- link_with: libots,
-- dependencies: gtest,
--)
--
--test('layout_common_table', layout_common_table)
--
--
--test('test_bad_fonts',
-- find_program('tests/test_bad_fonts.sh'),
-- env: [
-- 'top_srcdir=@0@'.format(meson.current_source_dir()),
-- 'top_builddir=@0@'.format(meson.current_build_dir()),
-- ]
--)
--
--
--test('test_fuzzed_fonts',
-- find_program('tests/test_fuzzed_fonts.sh'),
-- timeout: 9999,
-- env: [
-- 'top_srcdir=@0@'.format(meson.current_source_dir()),
-- 'top_builddir=@0@'.format(meson.current_build_dir()),
-- ]
--)
diff --git a/use-system-gtest.patch b/use-system-gtest.patch
new file mode 100644
index 000000000000..6966141024c6
--- /dev/null
+++ b/use-system-gtest.patch
@@ -0,0 +1,11 @@
+--- meson.build.orig 2020-11-11 21:17:53.653525712 +0200
++++ meson.build 2020-11-11 21:20:59.348612388 +0200
+@@ -303,7 +303,7 @@
+ endif
+
+
+-gtest = subproject('gtest').get_variable('gtest_main_dep')
++gtest = dependency('gtest_main')
+
+ cff_charstring = executable('cff_charstring',
+ 'tests/cff_charstring_test.cc',