summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Nikiforov2018-03-14 10:25:11 +0300
committerKonstantin Nikiforov2018-03-14 10:25:11 +0300
commit6bea1d28d75c3598066766211e7aeada0feb13de (patch)
treea45eed6fd079946b48738b2823aab9f26c3dfab5
parent56ebccc7bd80ee8e7524a21c42d4c323817bf4c2 (diff)
downloadaur-6bea1d28d75c3598066766211e7aeada0feb13de.tar.gz
Cleanup *.a files from usr/lib
Remove usr/lib if empty after cleanup. Add freetype2 to deps.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d039633ae89..94e2411776d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Mar 14 07:21:20 UTC 2018
pkgbase = ots-git
pkgdesc = OpenType fonts sanitiser. Supports TTF, WOFF, WOFF2 and other formats.
- pkgver = 324.b444494
+ pkgver = 641.f723823
pkgrel = 1
url = https://github.com/khaledhosny/ots
arch = i686
@@ -8,6 +10,8 @@ pkgbase = ots-git
license = custom
makedepends = git
depends = zlib
+ depends = freetype2
+ depends = libpng
provides = ots
conflicts = ots
source = git://github.com/khaledhosny/ots.git
diff --git a/PKGBUILD b/PKGBUILD
index 30903672baa9..e2c445c1f0b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
_gitname=ots
pkgname=${_gitname}-git
-pkgver=324.b444494
+pkgver=641.f723823
pkgver() { cd $_gitname && echo $(git rev-list --count master).$(git rev-parse --short master); }
pkgrel=1
pkgdesc="OpenType fonts sanitiser. Supports TTF, WOFF, WOFF2 and other formats."
arch=('i686' 'x86_64')
url="https://github.com/khaledhosny/ots"
license=('custom')
-depends=('zlib')
+depends=('zlib' 'freetype2' 'libpng')
makedepends=('git')
provides=('ots')
conflicts=('ots')
@@ -24,5 +24,15 @@ build() {
package() {
cd $_gitname
make DESTDIR="$pkgdir/" install
+
+ ## remove useless "libz.a" and others
+ thelibdir="$pkgdir/usr/lib"
+ rm $thelibdir/*.a
+
+ ## remove pkgdir/usr/lib, if it empty after *.a cleaup
+ if [ -z "$(ls -A $thelibdir)" ]; then
+ rm -d "$thelibdir"
+ fi
+
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}