summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2020-07-12 05:55:08 +0900
committerShohei Maruyama2020-07-12 05:55:08 +0900
commitc4656f39ecf8a43484ba69c159c02952dbcb0f49 (patch)
tree2c6b25ae61c9ef82e7ed3f0ba0aae117460b6f0f
parentd6c474aaf8cb959a2e5808f2506ffcb21a98eb82 (diff)
downloadaur-c4656f39ecf8a43484ba69c159c02952dbcb0f49.tar.gz
PKGBUILD: Change pkgver() to work correctly
This commit changes pkgver() to get the version of the source correctly.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c136559db5b0..c762797f34c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,8 @@ source=("git+${url}.git")
sha512sums=('SKIP')
pkgver() {
- echo 0
+ cd otto
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package_otto-kde-git() {