summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2020-07-12 05:37:47 +0900
committerShohei Maruyama2020-07-12 05:45:50 +0900
commitd6c474aaf8cb959a2e5808f2506ffcb21a98eb82 (patch)
treeaada0156346aaa4a660c0eb08bc91463d4432d13
downloadaur-d6c474aaf8cb959a2e5808f2506ffcb21a98eb82.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD45
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84cd13c9dc58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = otto-kde-git
+ pkgdesc = Complete Adapta theme pack for KDE Plasma using Kvantum theme engine (git version)
+ pkgver = 0
+ pkgrel = 1
+ url = https://www.opencode.net/jomada/otto
+ arch = any
+ license = GPL3
+ source = git+https://www.opencode.net/jomada/otto.git
+ sha512sums = SKIP
+
+pkgname = otto-kde-git
+ optdepends = konsole: For the Konsole color scheme
+ optdepends = kvantum-theme-otto-git: Otto theme for kvantum (recommended)
+
+pkgname = kvantum-theme-otto-git
+ pkgdesc = Otto theme for kvantum
+ depends = kvantum-qt5
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c136559db5b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Shohei Maruyama<cheat.sc.linux@outlook.com>
+
+pkgname=(otto-kde-git kvantum-theme-otto-git)
+pkgver=0
+pkgrel=1
+pkgdesc="Complete Adapta theme pack for KDE Plasma using Kvantum theme engine (git version)"
+arch=('any')
+url="https://www.opencode.net/jomada/otto"
+license=('GPL3')
+depends=()
+makedepends=()
+conflicts=()
+source=("git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ echo 0
+}
+
+package_otto-kde-git() {
+ optdepends=(
+ 'konsole: For the Konsole color scheme'
+ 'kvantum-theme-otto-git: Otto theme for kvantum (recommended)'
+ )
+
+ cd otto
+ install -d "${pkgdir}/usr/share"
+ install -d "${pkgdir}/usr/share/plasma"
+ install -d "${pkgdir}/usr/share/plasma/desktoptheme"
+
+ cp -r look-and-feel "${pkgdir}/usr/share/plasma"
+ cp -r Otto "${pkgdir}/usr/share/plasma/desktoptheme"
+ cp -r color-schemes "${pkgdir}/usr/share"
+ cp -r konsole "${pkgdir}/usr/share"
+}
+
+package_kvantum-theme-otto-git() {
+ pkgdesc="Otto theme for kvantum"
+ depends=(kvantum-qt5)
+
+ cd otto
+ install -d "${pkgdir}/usr/share"
+
+ cp -r kvantum "${pkgdir}/usr/share/Kvantum"
+}