summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2021-11-03 20:21:11 +0300
committerYigit Sever2021-11-03 20:21:31 +0300
commit17b3cd2b7f5e23d984906d90e47af15fe2aecb03 (patch)
treef61d6164126b32d4544caed976712c9aea7df393
parentbdceec7ad1c44b54291293d43207e05fd96f138b (diff)
downloadaur-17b3cd2b7f5e23d984906d90e47af15fe2aecb03.tar.gz
Add new conflict, install license
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76f50e6e4fba..4d033f8831b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ouch-git
pkgdesc = Painless compression and decompression in the terminal
pkgver = r385.a1c4f03
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ouch-org/ouch/
arch = x86_64
license = MIT
@@ -9,6 +9,7 @@ pkgbase = ouch-git
makedepends = cargo
provides = ouch
conflicts = ouch
+ conflicts = ouch-bin
source = ouch::git+https://github.com/ouch-org/ouch/
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index eb1611b97566..a6a1f1a519f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=ouch-git
_pkgname=${pkgname%-git}
-pkgver=r385.a1c4f03
-pkgrel=2
+pkgver=r389.2af0464
+pkgrel=1
pkgdesc="Painless compression and decompression in the terminal"
arch=('x86_64')
url="https://github.com/ouch-org/ouch/"
license=('MIT')
makedepends=('git' 'cargo')
-provides=($_pkgname)
-conflicts=($_pkgname)
+provides=(${_pkgname})
+conflicts=(${_pkgname} ${_pkgname}-bin)
source=("${_pkgname}::git+${url}")
sha256sums=('SKIP')
@@ -40,6 +40,7 @@ check() {
package() {
cd "$srcdir/${_pkgname}"
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
cd target/release/build/ouch-*/out/completions
sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch