summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 04:25:47 -0600
committerBrian Bidulock2015-06-10 04:25:47 -0600
commit177694293e1ed30cd83e75716fdead3bd60b62a1 (patch)
tree4c66083aaab1f4de1f046909da1e7e76232cee64
downloadaur-177694293e1ed30cd83e75716fdead3bd60b62a1.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--ourico.install9
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..488d44587acc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ourico
+ pkgdesc = A lightweight EWMH taskbar, originally designed for echinus
+ pkgver = 0.1.7
+ pkgrel = 1
+ url = http://freecode.com/projects/ourico
+ install = ourico.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libxft
+ conflicts = ourico-hg
+ source = http://plhk.ru/static/ourico/ourico-0.1.7.tar.gz
+ md5sums = 6b8af8bf5afc7b9b9f13500c25b19db4
+
+pkgname = ourico
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49b2075e3459
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: TDY <tdy@archlinux.info>
+
+pkgname=ourico
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="A lightweight EWMH taskbar, originally designed for echinus"
+arch=('i686' 'x86_64')
+url="http://freecode.com/projects/ourico"
+license=('MIT')
+depends=('libxft')
+conflicts=('ourico-hg')
+install=ourico.install
+source=(http://plhk.ru/static/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('6b8af8bf5afc7b9b9f13500c25b19db4')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's/\(CFLAGS \)= -Os/\1+= -g/; s/\(LDFLAGS \)= -s/\1+= -g/' config.mk
+ sed -i 's+usr/local/share/examples+etc/xdg+' $pkgname.1
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 ouricorc "$pkgdir/etc/xdg/$pkgname/ouricorc"
+ install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ourico.install b/ourico.install
new file mode 100644
index 000000000000..f1c91ea41a81
--- /dev/null
+++ b/ourico.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo " -> copy /etc/xdg/ourico/ouricorc to ~/.ouricorc"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: