summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-12 20:39:34 +0300
committerCaleb Maclennan2020-08-12 20:39:34 +0300
commit3f2f8da3807ac1d1cb667311ad3bce140fefacc7 (patch)
tree3439012941bb857c04b8637fc397c1cd58a38534
downloadaur-3f2f8da3807ac1d1cb667311ad3bce140fefacc7.tar.gz
Initial upload: ouroboros-font 2.000-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4834a696b8ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ouroboros-font
+ pkgdesc = A typeface from Velvetyne for alchemists, witches, heretics, outsiders and curious
+ pkgver = 2.000
+ pkgrel = 1
+ url = https://velvetyne.fr/fonts/ouroboros
+ arch = any
+ license = custom:Velvetyne Open License
+ source = https://gitlab.com/velvetyne/ouroboros/-/archive/0a35d93ed80ed2254bb8856a17a7da7bdb20c961/ouroboros-2.000.tar.bz2
+ sha256sums = 4fdb360960b663d87be5fe29343900a03842be3e4b5b376a09f276231654acd0
+
+pkgname = otf-ouroboros
+ provides = ouroboros-font
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fac29c4a714
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_name=ouroboros
+pkgbase=$_name-font
+pkgname=(otf-$_name)
+_sha=0a35d93ed80ed2254bb8856a17a7da7bdb20c961
+pkgver=2.000
+pkgrel=1
+pkgdesc='A typeface from Velvetyne for alchemists, witches, heretics, outsiders and curious'
+arch=('any')
+url="https://velvetyne.fr/fonts/$_name"
+license=('custom:Velvetyne Open License')
+source=("https://gitlab.com/velvetyne/$_name/-/archive/$_sha/$_name-$pkgver.tar.bz2")
+sha256sums=('4fdb360960b663d87be5fe29343900a03842be3e4b5b376a09f276231654acd0')
+
+package_otf-ouroboros() {
+ provides=("$pkgbase")
+ cd "$_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" fonts/*.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.txt
+}