summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornick black2019-10-26 13:15:10 -0400
committernick black2019-10-26 13:15:10 -0400
commit3c995f9bc2dd98e43cfbe032bed67b833633087f (patch)
tree3a0bcb5864b113ff7feeb4eace36ec3d9b3231fa
downloadaur-3c995f9bc2dd98e43cfbe032bed67b833633087f.tar.gz
Outcurses 0.0.4, initial AUR drop
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d39648aa1cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = outcurses
+ pkgdesc = High-level UI elements built atop ncurses
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://nick-black.com/dankwiki/index.php/Outcurses
+ arch = x86_64
+ license = Apache
+ makedepends = docbook-xsl
+ makedepends = autoconf-archive
+ makedepends = libxslt
+ makedepends = autoconf
+ depends = cryptsetup
+ depends = libatasmart
+ depends = libpciaccess
+ depends = pciutils
+ source = https://github.com/dankamongmen/outcurses/archive/v0.0.4.tar.gz
+ sha256sums = 0799e6b77ed6a00866dd2f24fc15d345a5908c8a81c742ddc1338f59b3d1adf1
+
+pkgname = outcurses
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c92f651afc11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nick Black <dankamongmen@gmail.com>
+
+pkgname=outcurses
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="High-level UI elements built atop ncurses"
+url="https://nick-black.com/dankwiki/index.php/Outcurses"
+license=('Apache')
+arch=('x86_64')
+# ncurses and readline are found without our help. Don't explicitly list them.
+# The same goes for device-mapper.
+depends=('cryptsetup' 'libatasmart' 'libpciaccess' 'pciutils')
+makedepends=('docbook-xsl' 'autoconf-archive' 'libxslt' 'autoconf')
+source=("https://github.com/dankamongmen/outcurses/archive/v${pkgver}.tar.gz")
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+sha256sums=('0799e6b77ed6a00866dd2f24fc15d345a5908c8a81c742ddc1338f59b3d1adf1')