summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbipin kumar2023-05-24 16:21:47 +0530
committerbipin kumar2023-05-24 16:21:47 +0530
commit9e99ada3d5ea715bce947eba31c8e4cca39a2e7d (patch)
tree53a5cab9c821ed220f373a17bd15c691c6bbfac5
downloadaur-9e99ada3d5ea715bce947eba31c8e4cca39a2e7d.tar.gz
outils: version 0.12
-rw-r--r--.SRCINFO28
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD52
3 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b7eb54d09ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = outils
+ pkgdesc = A port of some non-standard OpenBSD tools to Linux
+ pkgver = 0.12
+ pkgrel = 1
+ url = https://github.com/leahneukirchen/outils
+ arch = x86_64
+ license = BSD
+ depends = glibc
+ provides = apply
+ provides = calendar
+ provides = ou-cksum
+ provides = jot
+ provides = lam
+ provides = lndir
+ provides = md5
+ provides = rdate
+ provides = rs
+ provides = ts
+ provides = signify
+ provides = unvis
+ provides = vis
+ provides = what
+ source = outils-0.12.tar.gz::https://github.com/leahneukirchen/outils/archive/refs/tags/v0.12.tar.gz
+ source = LICENSE
+ b2sums = a329dd4e7fe666af561ca554e3f30b2188fab3c0ca6b4c201d7eb121785a2f5aca332fdd4e76896332cea84a2eca5a075836e34809fa6f459d5e72a1a3cbfa73
+ b2sums = 3f242af7ea42dc13ba0a124da5861249b95195351fd181c86420c5e2580b8760f24574fe53062f7594071812958d1081e21fd3a7a78832a7a73eb441bead1231
+
+pkgname = outils
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8327c0ad079e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+License:
+
+ * Copyright (c) 1993
+ * The Regents of the University of California. All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a5ea7c526ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer:Bipin Kumar <kbipinkumar@pm.me>
+
+pkgname=outils
+pkgver=0.12
+pkgrel=1
+pkgdesc="A port of some non-standard OpenBSD tools to Linux"
+arch=('x86_64')
+url="https://github.com/leahneukirchen/outils"
+license=('BSD')
+depends=('glibc')
+provides=('apply'
+ 'calendar'
+ 'ou-cksum'
+ 'jot'
+ 'lam'
+ 'lndir'
+ 'md5'
+ 'rdate'
+ 'rs'
+ 'ts'
+ 'signify'
+ 'unvis'
+ 'vis'
+ 'what')
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/leahneukirchen/outils/archive/refs/tags/v${pkgver}.tar.gz"
+ 'LICENSE')
+b2sums=('a329dd4e7fe666af561ca554e3f30b2188fab3c0ca6b4c201d7eb121785a2f5aca332fdd4e76896332cea84a2eca5a075836e34809fa6f459d5e72a1a3cbfa73'
+ '3f242af7ea42dc13ba0a124da5861249b95195351fd181c86420c5e2580b8760f24574fe53062f7594071812958d1081e21fd3a7a78832a7a73eb441bead1231')
+
+prepare(){
+ rm "$pkgname-$pkgver"/LICENSE
+ cp LICENSE "$pkgname-$pkgver"/
+ cd "$pkgname-$pkgver"/
+ # set proper LDFLAGS as recommended by Archlinux pacakging guidelines
+ sed -i 's/-Wl,--as-needed/-Wl,-O2,--sort-common,--as-needed,-z,relro,-z,now/g' Makefile
+ # cksum binary from package is in conflict with 'cksum' provided by 'coreutils'. Hence the former is renamed to ou-cksum
+ sed -i 's/cksum/ou-cksum/g' Makefile
+ sed -i 's/cksum/ou-cksum/g' src/bin/md5/Makefile
+ mv src/bin/md5/cksum.1 src/bin/md5/ou-cksum.1
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
+}