summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-05-24 18:01:14 +0000
committerBioArchLinuxBot2023-05-24 18:01:14 +0000
commitd92812ac351bdf26470ea452875ab622f06273b9 (patch)
treed446b4e42f23876df215412e22c784caa5570070
parent9e99ada3d5ea715bce947eba31c8e4cca39a2e7d (diff)
downloadaur-d92812ac351bdf26470ea452875ab622f06273b9.tar.gz
[lilac] updated to 0.12-2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b7eb54d09ca..4aa65272071c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = outils
pkgdesc = A port of some non-standard OpenBSD tools to Linux
pkgver = 0.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/leahneukirchen/outils
arch = x86_64
license = BSD
depends = glibc
provides = apply
- provides = calendar
provides = ou-cksum
provides = jot
provides = lam
diff --git a/PKGBUILD b/PKGBUILD
index 0a5ea7c526ed..7ec8d514ba82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
pkgname=outils
pkgver=0.12
-pkgrel=1
+pkgrel=2
pkgdesc="A port of some non-standard OpenBSD tools to Linux"
arch=('x86_64')
url="https://github.com/leahneukirchen/outils"
license=('BSD')
depends=('glibc')
provides=('apply'
- 'calendar'
'ou-cksum'
'jot'
'lam'
@@ -32,8 +31,13 @@ prepare(){
rm "$pkgname-$pkgver"/LICENSE
cp LICENSE "$pkgname-$pkgver"/
cd "$pkgname-$pkgver"/
- # set proper LDFLAGS as recommended by Archlinux pacakging guidelines
- sed -i 's/-Wl,--as-needed/-Wl,-O2,--sort-common,--as-needed,-z,relro,-z,now/g' Makefile
+ # set proper LDFLAGS as recommended by Archlinux packging guidelines
+ sed -i 's|-Wl,--as-needed|-Wl,-O2,--sort-common,--as-needed,-z,relro,-z,now|g' Makefile
+ # calendar is also part of bsdmainutils. hence building same has to be disabled in the makefile
+ sed -i '58d' Makefile
+ sed -i '57d' Makefile
+ sed -i '28d' Makefile
+ sed -i 's/src\/usr\.bin\/calendar\/calendar//g' Makefile
# cksum binary from package is in conflict with 'cksum' provided by 'coreutils'. Hence the former is renamed to ou-cksum
sed -i 's/cksum/ou-cksum/g' Makefile
sed -i 's/cksum/ou-cksum/g' src/bin/md5/Makefile
@@ -48,5 +52,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+ # remove man entry fro calendar as the same is not part of the package
+ rm ${pkgdir}/usr/share/man/man1/calendar.1
install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
}