summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-05-16 17:51:13 -0500
committerLuis Martinez2022-05-16 17:51:13 -0500
commitb6c930594bb9fe081bb218c45a6ae06c0b981393 (patch)
tree175258c1f861dc63eae659442ef4285d0821f213
parenteec938d48a5fe624f66a91c599eaa67ae92930d5 (diff)
downloadaur-b6c930594bb9fe081bb218c45a6ae06c0b981393.tar.gz
update to 3.1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8fa735afdc8..74b7f162abab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = outwiker
pkgdesc = Outliner and personal wiki with keeping the tree of notes in the form of directories on a disk
- pkgver = 3.0.0.888
+ pkgver = 3.1.0.900
pkgrel = 1
- url = https://jenyay.net/Outwiker/English
+ url = https://github.com/jenyay/outwiker
arch = any
license = GPL3
makedepends = python-setuptools
- depends = python-cyhunspell
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-idna
depends = python-pillow
+ depends = python-psutil
depends = python-pyparsing
depends = python-wxpython
- source = https://github.com/Jenyay/outwiker/archive/stable_3.0.0.888/outwiker-3.0.0.888.tar.gz
- sha256sums = 5ac7b6654bef38bf57e98daddfd001e203020db96f97844eb0dfec3f2d7421ec
+ source = outwiker-3.1.0.900.tar.gz::https://github.com/jenyay/outwiker/archive/stable_3.1.0.900/outwiker-3.1.0.900.tar.gz
+ sha256sums = f4444811722dc8cf9afb967bf0bd07cf9e97eff46ce28564097c1b039af35ee3
pkgname = outwiker
-
diff --git a/PKGBUILD b/PKGBUILD
index 81e5053cecbb..8279fd64b4ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Balló György <ballogyor+arch at gmail dot com>
# Contributor: Felix Golatofski <contact@xdfr.de>
pkgname=outwiker
-pkgver=3.0.0.888
+pkgver=3.1.0.900
pkgrel=1
pkgdesc='Outliner and personal wiki with keeping the tree of notes in the form of directories on a disk'
arch=('any')
-url='https://jenyay.net/Outwiker/English'
+url='https://github.com/jenyay/outwiker'
license=('GPL3')
-depends=('python-cyhunspell' 'python-idna' 'python-pillow' 'python-pyparsing' 'python-wxpython')
-makedepends=('python-setuptools')
-source=("https://github.com/Jenyay/$pkgname/archive/stable_$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('5ac7b6654bef38bf57e98daddfd001e203020db96f97844eb0dfec3f2d7421ec')
+depends=('python-idna' 'python-pillow' 'python-psutil' 'python-pyparsing' 'python-wxpython')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/stable_$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('f4444811722dc8cf9afb967bf0bd07cf9e97eff46ce28564097c1b039af35ee3')
build() {
- cd $pkgname-stable_$pkgver
- python setup.py build
+ cd "$pkgname-stable_${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd $pkgname-stable_$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-stable_${pkgver}"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ make DESTDIR="$pkgdir" install
}