summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrayich2015-07-04 19:08:46 +0300
committergrayich2015-07-04 19:08:46 +0300
commitc7222d9bbcaad2a68bffd6e26f08d04e1a21dc08 (patch)
tree959c2e06d203bdb40686f92f88158a65f4068298
downloadaur-c7222d9bbcaad2a68bffd6e26f08d04e1a21dc08.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1b50e506397
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = outwiker
+ pkgdesc = Outliner and personal wiki with keeping the tree of notes in the form of directories on a disk
+ pkgver = 1.8.1
+ pkgrel = 1
+ url = http://jenyay.net/Outwiker/English
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = wxpython2.8
+ depends = pywebkitgtk
+ depends = python2-pillow
+ optdepends = mimetex: rendering of formulas
+ optdepends = python-gnomeprint: printing non-latin symbols
+ conflicts = outwiker-git
+ source = outwiker.deb::https://launchpad.net/~outwiker-team/+archive/ubuntu/ppa/+files/outwiker_1.8.1%2B752%7Etrusty_all.deb
+ sha1sums = f876cf2723162148508f1cf791e3069f27885b10
+
+pkgname = outwiker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d95c434e7dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+
+pkgname=outwiker
+pkgver=1.8.1
+pkgrel=1
+arch=('any')
+pkgdesc="Outliner and personal wiki with keeping the tree of notes in the form of directories on a disk"
+url="http://jenyay.net/Outwiker/English"
+license=('GPL3')
+depends=('python2' 'wxpython2.8' 'pywebkitgtk' 'python2-pillow')
+optdepends=('mimetex: rendering of formulas'
+ 'python-gnomeprint: printing non-latin symbols')
+conflicts=('outwiker-git')
+source=("outwiker.deb::https://launchpad.net/~outwiker-team/+archive/ubuntu/ppa/+files/outwiker_1.8.1%2B752%7Etrusty_all.deb")
+sha1sums=('f876cf2723162148508f1cf791e3069f27885b10')
+
+package() {
+ ar x outwiker.deb
+ tar xf data.tar.xz -C ${pkgdir}
+ cd ${pkgdir}
+ # python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+ sed -i -e 's/python /python2 /' ${pkgdir}/usr/bin/${pkgname}
+ find ${pkgdir}/usr/share/${pkgname} -type f -exec chmod a-x,u+w {} \;
+}