summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2021-05-26 15:08:40 +0000
committerBalló György2021-05-26 15:08:40 +0000
commiteec938d48a5fe624f66a91c599eaa67ae92930d5 (patch)
tree7d617d4a027a35ca09cb540dcfa8ae313fbdd2a9
parent8aeed6f0c75cbae5ccc3df1e97001bd213b69358 (diff)
downloadaur-eec938d48a5fe624f66a91c599eaa67ae92930d5.tar.gz
Update to version 3.0.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 28 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3180647a36a..d8fa735afdc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = outwiker
pkgdesc = Outliner and personal wiki with keeping the tree of notes in the form of directories on a disk
- pkgver = 2.0.0
- pkgrel = 2
+ pkgver = 3.0.0.888
+ pkgrel = 1
url = https://jenyay.net/Outwiker/English
arch = any
license = GPL3
- depends = python2
- depends = wxpython2.8
- depends = pywebkitgtk
- depends = python2-pillow
- depends = python2-pyenchant
- optdepends = mimetex: rendering of formulas
- conflicts = outwiker-git
- source = outwiker.deb::https://launchpad.net/~outwiker-team/+archive/ubuntu/ppa/+files/outwiker_2.0.0+822~zesty_all.deb
- sha256sums = 4d0dd13dce875ebfe359818e9a3bec127f6af53f21100138e5fbd8caf9cc9021
+ makedepends = python-setuptools
+ depends = python-cyhunspell
+ depends = python-idna
+ depends = python-pillow
+ depends = python-pyparsing
+ depends = python-wxpython
+ source = https://github.com/Jenyay/outwiker/archive/stable_3.0.0.888/outwiker-3.0.0.888.tar.gz
+ sha256sums = 5ac7b6654bef38bf57e98daddfd001e203020db96f97844eb0dfec3f2d7421ec
pkgname = outwiker
diff --git a/PKGBUILD b/PKGBUILD
index e9c047ce1d06..81e5053cecbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Felix Golatofski <contact@xdfr.de>
pkgname=outwiker
-pkgver=2.0.0
-pkgrel=2
+pkgver=3.0.0.888
+pkgrel=1
+pkgdesc='Outliner and personal wiki with keeping the tree of notes in the form of directories on a disk'
arch=('any')
-pkgdesc="Outliner and personal wiki with keeping the tree of notes in the form of directories on a disk"
-url="https://jenyay.net/Outwiker/English"
+url='https://jenyay.net/Outwiker/English'
license=('GPL3')
-depends=('python2' 'wxpython2.8' 'pywebkitgtk' 'python2-pillow' 'python2-pyenchant')
-optdepends=('mimetex: rendering of formulas')
-conflicts=('outwiker-git')
-source=("outwiker.deb::https://launchpad.net/~outwiker-team/+archive/ubuntu/ppa/+files/outwiker_2.0.0+822~zesty_all.deb");
-sha256sums=('4d0dd13dce875ebfe359818e9a3bec127f6af53f21100138e5fbd8caf9cc9021')
+depends=('python-cyhunspell' 'python-idna' 'python-pillow' 'python-pyparsing' 'python-wxpython')
+makedepends=('python-setuptools')
+source=("https://github.com/Jenyay/$pkgname/archive/stable_$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('5ac7b6654bef38bf57e98daddfd001e203020db96f97844eb0dfec3f2d7421ec')
+
+build() {
+ cd $pkgname-stable_$pkgver
+ python setup.py build
+}
package() {
- ar x outwiker.deb
- tar xf data.tar.xz -C ${pkgdir}
- cd ${pkgdir}
- # python2 fix
- for file in $(find . -name '*.py' -print); do
- sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
- sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
- done
- sed -i -e 's/python /python2 /' ${pkgdir}/usr/bin/${pkgname}
- find ${pkgdir}/usr/share/${pkgname} -type f -exec chmod a-x,u+w {} \;
+ cd $pkgname-stable_$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ make DESTDIR="$pkgdir" install
}