summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Smith2021-11-22 15:49:55 -0700
committerAdrien Smith2021-11-22 15:49:55 -0700
commit1af349536c4913cba529fe2bbbc3eb120ecb74e3 (patch)
tree22cdfe8e33dbe0fb2c4c7aeea478f37ccd89354a
parentfd204756ecb2ed80a3dd75a2cca353a3ca983f2f (diff)
downloadaur-1af349536c4913cba529fe2bbbc3eb120ecb74e3.tar.gz
Ensure user build options are used
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59b553a87888..88f3dbbf5909 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = overmind
pkgdesc = Process manager for Procfile-based applications and tmux
pkgver = 2.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/DarthSim/overmind
arch = x86_64
license = MIT
@@ -14,4 +14,3 @@ pkgbase = overmind
b2sums = 0caafb16472bb0c3ea369347156cda929bb8e16ba19b758c61ed0c87ad946b93528f506c675b73da80becc7935a35930f8778e14eea0076c5aa1969b7721fd87
pkgname = overmind
-
diff --git a/PKGBUILD b/PKGBUILD
index a4b47a36db06..e25185604a0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
-# Maintainer: Adrien Smith <adrien at bouldersmiths dot com>
+#!/hint/bash -e
+# Maintainer: Adrien Smith <adrien@panissupraomnia.dev>
+
pkgname=overmind
pkgver=2.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Process manager for Procfile-based applications and tmux"
arch=("x86_64")
url="https://github.com/DarthSim/$pkgname"
@@ -15,17 +17,18 @@ b2sums=('0caafb16472bb0c3ea369347156cda929bb8e16ba19b758c61ed0c87ad946b93528f506
build() {
cd "$pkgname-$pkgver"
- go build \
- -trimpath \
- -buildmode=pie \
- -mod=readonly \
- -modcacherw \
- -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
- -o $pkgname .
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o $pkgname .
}
package() {
cd "$pkgname-$pkgver"
+
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}