summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchn2021-04-29 10:13:25 +0800
committerchn2021-04-29 10:13:25 +0800
commit1c48860118864b73791acd42c43be81c9c46592c (patch)
treea3f8ecd7575cffe1475a16996f4b89c43a59e7e6
parent556aa2e3388c6d10f7af49128dfd15c84af847b7 (diff)
downloadaur-1c48860118864b73791acd42c43be81c9c46592c.tar.gz
3.4.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--ovito.desktop10
3 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbdef882480c..5ba6a4bbd320 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ovito
pkgdesc = Open Visualization Tool
- pkgver = 3.3.4
+ pkgver = 3.4.4
pkgrel = 1
url = http://www.ovito.org
arch = x86_64
@@ -17,8 +17,12 @@ pkgbase = ovito
depends = ffmpeg
depends = qt5-base
conflicts = ovito-git
- source = https://gitlab.com/stuko/ovito/-/archive/v3.3.4/ovito-v3.3.4.tar.bz2
- sha256sums = 3ba11673e3dc4f82e4bac4df22df5069975f6383661e2c51628f47040b9aab76
+ source = https://gitlab.com/stuko/ovito/-/archive/v3.4.4/ovito-v3.4.4.tar.bz2
+ source = https://www.ovito.org/wp-content/uploads/logo_rgb-768x737.png
+ source = ovito.desktop
+ sha256sums = 6d2c6f1fdc0d5022156d1a172264d822fca0e9ed5ea8aed80315497360fd123d
+ sha256sums = 14e98851e5de9bee0c8dabd035a83450895c476c1ad9e9898e2bf0c68261e9f2
+ sha256sums = 09b16de717b1b4140678d17958dcee2ea96ff5ae3a1c75f3168a0ad17f62f4ea
pkgname = ovito
diff --git a/PKGBUILD b/PKGBUILD
index 0a91cb6bb331..ad007590a159 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Maintainer: chn <g897331845@gmail.com>
# Contributor: Ross Whitfield <whitfieldre@ornl.gov>
# Contributor: Brian Lam <blamm9[at]gmail[dot]com>
# Contributor: AG_Caesar <caesar[at]drachenhain[dot]net>
# Contributor: Jan Oliver Oelerich <janoliver[at]oelerich[dot]org>
pkgname=ovito
-pkgver=3.3.4
+pkgver=3.4.4
pkgrel=1
pkgdesc="Open Visualization Tool"
url="http://www.ovito.org"
@@ -14,8 +15,12 @@ license=('GPL')
depends=('fftw' 'python' 'netcdf' 'ffmpeg' 'qt5-base')
makedepends=('cmake' 'boost' 'qscintilla-qt5' 'qt5-svg' 'libxslt' 'git')
conflicts=("$pkgname-git")
-source=("https://gitlab.com/stuko/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.bz2")
-sha256sums=('3ba11673e3dc4f82e4bac4df22df5069975f6383661e2c51628f47040b9aab76')
+source=("https://gitlab.com/stuko/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.bz2"
+ "https://www.ovito.org/wp-content/uploads/logo_rgb-768x737.png"
+ "ovito.desktop")
+sha256sums=('6d2c6f1fdc0d5022156d1a172264d822fca0e9ed5ea8aed80315497360fd123d'
+ '14e98851e5de9bee0c8dabd035a83450895c476c1ad9e9898e2bf0c68261e9f2'
+ '09b16de717b1b4140678d17958dcee2ea96ff5ae3a1c75f3168a0ad17f62f4ea')
prepare() {
mkdir -p "$srcdir/build"
@@ -33,4 +38,8 @@ build() {
package() {
cd "$srcdir/build"
make DESTDIR="$pkgdir" install
+ mkdir -p "${pkgdir}/usr/share/pixmaps/"
+ install -m 644 "${srcdir}/logo_rgb-768x737.png" "${pkgdir}/usr/share/pixmaps/ovito.png"
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ install -m 644 "${srcdir}/ovito.desktop" "${pkgdir}/usr/share/applications/"
}
diff --git a/ovito.desktop b/ovito.desktop
new file mode 100644
index 000000000000..4f1785231790
--- /dev/null
+++ b/ovito.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=OVITO
+Comment=Open Visualization Tool
+Exec=ovito
+Icon=ovito
+Terminal=false
+StartupNotify=false
+Categories=Education;Science;Mathematics;