summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-02 08:31:49 -0500
committerCarlos Aznarán2024-02-02 08:31:49 -0500
commit3bea3e6d7714b6d947f452055c1be9be2242c38d (patch)
tree9979f80b75b9ca1da99791514544b5db6830b805
parentcfeab4b7542caa7a7ee23da00ffb61276694ae62 (diff)
downloadaur-3bea3e6d7714b6d947f452055c1be9be2242c38d.tar.gz
Do not build vulkan plugin
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e509259324a0..30068825576c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ovito
pkgdesc = Open Visualization Tool
pkgver = 3.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.ovito.org
arch = x86_64
arch = aarch64
@@ -12,8 +12,6 @@ pkgbase = ovito
makedepends = qt6-svg
makedepends = libxslt
makedepends = python-sphinx_rtd_theme
- makedepends = vulkan-icd-loader
- makedepends = vulkan-headers
depends = netcdf-openmpi
depends = ffmpeg
depends = qt6-base
diff --git a/PKGBUILD b/PKGBUILD
index 5fc26c3492e3..018c0a1ba5dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Anton Kudelin <kudelin at proton dot me>
# Contributor: chn <g897331845@gmail.com>
# Contributor: Ross Whitfield <whitfieldre@ornl.gov>
# Contributor: Brian Lam <blamm9[at]gmail[dot]com>
# Contributor: AG_Caesar <caesar[at]drachenhain[dot]net>
# Contributor: Jan Oliver Oelerich <janoliver[at]oelerich[dot]org>
-
pkgname=ovito
pkgver=3.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Open Visualization Tool"
url="https://www.${pkgname}.org"
arch=(x86_64 aarch64)
license=(GPL)
depends=(netcdf-openmpi ffmpeg qt6-base)
-makedepends=(cmake boost qscintilla-qt6 qt6-svg libxslt python-sphinx_rtd_theme vulkan-icd-loader vulkan-headers) # git
+makedepends=(cmake boost qscintilla-qt6 qt6-svg libxslt python-sphinx_rtd_theme)
conflicts=($pkgname-git)
source=(https://gitlab.com/stuko/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.bz2
${url}/wp-content/uploads/logo_rgb-768x737.png
@@ -31,8 +31,7 @@ build() {
-DCMAKE_CXX_STANDARD=20 \
-DOpenGL_GL_PREFERENCE=GLVND \
-DOVITO_BUILD_DOCUMENTATION=ON \
- -DOVITO_BUILD_PLUGIN_VULKAN=ON \
- -DVulkan_INCLUDE_DIR=/usr/include
+ -DOVITO_BUILD_PLUGIN_VULKAN=OFF
cmake --build build --target all
}