summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2019-10-16 17:22:29 +0300
committerAnton Kudelin2019-10-16 17:22:29 +0300
commitcb23d0134a310c4fe49f4d501a1144dc2c9d2a09 (patch)
treeb26e384eb27f691d276060ed3f3cd93b660d4f29
parent72a3265a46d26ee5aef32225abae36fd241f43ce (diff)
downloadaur-cb23d0134a310c4fe49f4d501a1144dc2c9d2a09.tar.gz
Building from source
-rw-r--r--.SRCINFO21
-rw-r--r--9.patch32
-rw-r--r--PKGBUILD52
3 files changed, 83 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0715454108e5..b45a88ea8b66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,23 @@
pkgbase = ovito
- pkgdesc = A scientific visualization and analysis software for atomistic simulation data.
+ pkgdesc = Open Visualization Tool
pkgver = 2.9.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.ovito.org
arch = x86_64
- license = GPL3
+ license = GPL
+ makedepends = cmake
+ depends = boost
+ depends = qscintilla-qt5
+ depends = muparser
+ depends = fftw
+ depends = openbabel
depends = python
- depends = qt5-svg
- depends = ffmpeg2.8
+ depends = netcdf
conflicts = ovito-git
- source = http://www.ovito.org/download/2.9.0/ovito-2.9.0-x86_64.tar.gz
- md5sums = 65f8eb93e96145c556e9b04499f924b0
+ source = https://gitlab.com/stuko/ovito/-/archive/v2.9.0/ovito-v2.9.0.tar.bz2
+ source = 9.patch
+ sha256sums = 8670a5c4fc0199d80e4cf2e96ef1c595c7988bd59fe48e67caebce1713fb1994
+ sha256sums = 154836944fd3ec19411a12e6e6392268406150c186126ff91493500b5ccb6d71
pkgname = ovito
diff --git a/9.patch b/9.patch
new file mode 100644
index 000000000000..e75a1502143b
--- /dev/null
+++ b/9.patch
@@ -0,0 +1,32 @@
+diff --git a/cmake/FindQScintilla.cmake b/cmake/FindQScintilla.cmake
+index ff7f0021afccd7c4d181360fc6f68ebb6bec9817..7124576b244caf9e0db540d1934bbe4b5737cf65 100644
+--- a/cmake/FindQScintilla.cmake
++++ b/cmake/FindQScintilla.cmake
+@@ -4,7 +4,7 @@
+ # QScintilla_LIBRARIES - libraries needed
+
+ FIND_PATH(QSCINTILLA_INCLUDE_DIR NAMES Qsci/qsciscintilla.h PATH_SUFFIXES qt5 qt)
+-FIND_LIBRARY(QSCINTILLA_LIBRARY NAMES qsciscintilla qt5scintilla2 qscintilla2)
++FIND_LIBRARY(QSCINTILLA_LIBRARY NAMES qsciscintilla qt5scintilla2 qscintilla2_qt5 qscintilla2)
+
+ SET(QScintilla_INCLUDE_DIRS ${QSCINTILLA_INCLUDE_DIR})
+ SET(QScintilla_LIBRARIES ${QSCINTILLA_LIBRARY})
+diff --git a/src/core/reference/PropertyField.h b/src/core/reference/PropertyField.h
+index 5d77d9cb6f207985aff82b536b98afcf08ee4098..5021d1ae77c63eb39ecdb36c5bf791aa5523960d 100755
+--- a/src/core/reference/PropertyField.h
++++ b/src/core/reference/PropertyField.h
+@@ -159,10 +159,12 @@ private:
+ // This undo class records a change to the property value.
+ class PropertyChangeOperation : public UndoableOperation {
+ public:
+- PropertyChangeOperation(PropertyField& field) : _field(field), _owner(field.owner() != field.owner()->dataset() ? field.owner() : nullptr) {
++ PropertyChangeOperation(PropertyField& field) : _field(field) {
+ // Make a copy of the current property value.
++ _owner = field.owner() != dynamic_cast<Ovito::RefMaker*>(field.owner()->dataset()) ? field.owner() : nullptr;
+ _oldValue = field;
+ }
++
+ /// Restores the old property value.
+ virtual void undo() override {
+ // Swap old value and current property value.
+
diff --git a/PKGBUILD b/PKGBUILD
index bc4dd498ddeb..1daca5b4c564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,44 @@
-# Maintainer: Ross Whitfield <whitfieldre@ornl.gov>
-# Contributor: Brian Lam <blamm9[at]gmail[dot]com>
-# Contributor: AG_Caesar <caesar[at]drachenhain[dot]net>
-# Contributor: Jan Oliver Oelerich <janoliver[at]oelerich[dot]org>
+# Maintainter: Anton Kudelin <kudelin at protonmail dot com>
+# Contributor: Ross Whitfield <whitfieldre@ornl.gov>
+# Contributor: Brian Lam <blamm9[at]gmail[dot]com>
+# Contributor: AG_Caesar <caesar[at]drachenhain[dot]net>
+# Contributor: Jan Oliver Oelerich <janoliver[at]oelerich[dot]org>
+
pkgname=ovito
pkgver=2.9.0
-pkgrel=1
-pkgdesc="A scientific visualization and analysis software for atomistic simulation data."
+pkgrel=2
+pkgdesc="Open Visualization Tool"
url="http://www.ovito.org"
arch=('x86_64')
-license=('GPL3')
-depends=('python' 'qt5-svg' 'ffmpeg2.8')
-conflicts=('ovito-git')
-md5sums=('65f8eb93e96145c556e9b04499f924b0')
-source=("http://www.ovito.org/download/$pkgver/$pkgname-$pkgver-$CARCH.tar.gz")
+license=('GPL')
+depends=('boost' 'qscintilla-qt5' 'muparser' 'fftw'
+ 'openbabel' 'python' 'netcdf')
+makedepends=('cmake')
+conflicts=("$pkgname-git")
+source=("https://gitlab.com/stuko/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.bz2"
+ "9.patch")
+sha256sums=('8670a5c4fc0199d80e4cf2e96ef1c595c7988bd59fe48e67caebce1713fb1994'
+ '154836944fd3ec19411a12e6e6392268406150c186126ff91493500b5ccb6d71')
+
+prepare() {
+ cd $srcdir/$pkgname-v$pkgver
+ patch -p1 < ../9.patch
+ mkdir $srcdir/build
+ sed -i "s/ CODEC_FLAG_GLOBAL_HEADER/AV_CODEC_FLAG_GLOBAL_HEADER/g" src/core/utilities/io/video/VideoEncoder.cpp
+ sed -i "s/\/resources//g" src/plugins/openbabel/CMakeLists.txt
+}
+
+build() {
+ cd $srcdir/build
+ cmake ../$pkgname-v$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DOVITO_BUILD_PLUGIN_OPENBABELPLUGIN=ON \
+ -DOPENBABEL_INCLUDE_DIR=/usr/include/openbabel3
+ make
+}
package() {
- cd ${pkgname}-${pkgver}-$CARCH
- install -d ${pkgdir}/usr
- rm -rf LICENSE.txt README.txt
- cp -dpr --no-preserve=ownership ./* ${pkgdir}/usr
+ cd $srcdir/build
+ make DESTDIR=$pkgdir install
+ mv $pkgdir/usr/*.txt $pkgdir/usr/share/$pkgname
}