summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2014-05-19 01:10:07 -0400
committerKeshav Amburay2014-05-19 01:10:07 -0400
commit0e5cf15c44cef41cc1808b785be3918a5fcd664d (patch)
treefc37b32f416cc5e799bcf481baa58d44f6e21cd0
parent9dcc3680c5810c9b6a60df64896b68ea4b67b1b2 (diff)
downloadaur-0e5cf15c44cef41cc1808b785be3918a5fcd664d.tar.gz
Not building yet
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2be693a001eb..171a64b09fd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ovmf-svn
pkgdesc = UEFI Firmware (OVMF) with Secure Boot Support - for Virtual Machines (QEMU) - from Tianocore EDK2 - SVN Version
- pkgver = 15536
+ pkgver = 15537
pkgrel = 1
url = http://sourceforge.net/apps/mediawiki/tianocore/index.php?title=OVMF
install = ovmf.install
diff --git a/PKGBUILD b/PKGBUILD
index ebd1e105ec28..fcb6c094b114 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ _OPENSSL_VERSION="0.9.8w"
_pkgname="ovmf"
pkgname="${_pkgname}-svn"
-pkgver=15536
+pkgver=15537
pkgrel=1
pkgdesc="UEFI Firmware (OVMF) with Secure Boot Support - for Virtual Machines (QEMU) - from Tianocore EDK2 - SVN Version"
url="http://sourceforge.net/apps/mediawiki/tianocore/index.php?title=OVMF"
@@ -134,10 +134,16 @@ _prepare_tianocore_sources() {
sed 's|--64 | |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
sed 's| -m64 -melf_x86_64| -m64|g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
- msg "Remove GCC -g debug option and add -0s -mabi=ms"
+ msg "Remove GCC -g debug option and add -O0 -mabi=ms -maccumulate-outgoing-args"
sed 's|DEFINE GCC_ALL_CC_FLAGS = -g |DEFINE GCC_ALL_CC_FLAGS = -O0 -mabi=ms -maccumulate-outgoing-args |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
sed 's|DEFINE GCC44_ALL_CC_FLAGS = -g |DEFINE GCC44_ALL_CC_FLAGS = -O0 -mabi=ms -maccumulate-outgoing-args |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
+ msg "Fix GenFw: ERROR 3000: Invalid, Unsupported section alignment"
+ sed 's|Error (NULL, 0, 3000, "Invalid", "Unsupported section alignment.");|continue;|g' -i "${EDK_TOOLS_PATH}/Source/C/GenFw/Elf64Convert.c"
+ sed 's|Error (NULL, 0, 3000, "Invalid", "Unsupported section alignment.");|continue;|g' -i "${EDK_TOOLS_PATH}/Source/C/GenFw/Elf32Convert.c"
+ # sed 's|_GCC48_IA32_OBJCOPY_FLAGS =|_GCC48_IA32_OBJCOPY_FLAGS = --section-alignment=0x20 |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
+ # sed 's|_GCC48_X64_OBJCOPY_FLAGS =|_GCC48_X64_OBJCOPY_FLAGS = --section-alignment=0x20 |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
+
msg "Fix UDK Target Platform"
sed "s|ACTIVE_PLATFORM = Nt32Pkg/Nt32Pkg.dsc|ACTIVE_PLATFORM = ${_UDK_OVMF_X64_DSC}|g" -i "${EDK_TOOLS_PATH}/Conf/target.template" || true
sed "s|TARGET = DEBUG|TARGET = ${_UDK_TARGET}|g" -i "${EDK_TOOLS_PATH}/Conf/target.template" || true