summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2012-04-10 19:29:24 +0530
committerKeshav Amburay2012-04-10 19:29:24 +0530
commit50eee993f950d1a1d00710184c7b6f7148f63f15 (patch)
tree19266bd4f09f9979858de152993138d6e20b4ef3
parent3208c40c06e72bbe664266b20902b966a35e5871 (diff)
downloadaur-50eee993f950d1a1d00710184c7b6f7148f63f15.tar.gz
B
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--refind_include_more_shell_paths.patch19
3 files changed, 32 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b708761a3ca..54c206835f2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = refind-x86_64-git
pkgdesc = Rod Smith's fork of rEFIt (U)EFI Boot Manager - GIT Version
- pkgver = 20120405
+ pkgver = 20120410
pkgrel = 1
url = http://www.rodsbooks.com/refind/index.html
install = refind-x86_64.install
@@ -18,7 +18,9 @@ pkgbase = refind-x86_64-git
options = docs
backup = boot/efi/efi/arch_refind/refind.conf
backup = boot/efi/efi/arch_refind/refind_linux.conf
+ source = refind_include_more_shell_paths.patch
source = refind_linux.conf
+ sha256sums = a46ef102eadfd1cf9e43527ed8409d3d9f69e96c8136132b3448c4524ed9ea89
sha256sums = 9aac6e65018965ba182ec2d246d37fc5f9269ae96504956d8a51355c3ba1b62f
pkgname = refind-x86_64-git
diff --git a/PKGBUILD b/PKGBUILD
index 9780885c5797..5da06eb5a39d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _actualname="refind"
_pkgname="${_actualname}-x86_64"
pkgname="${_pkgname}-git"
-pkgver=20120405
+pkgver=20120410
pkgrel=1
pkgdesc="Rod Smith's fork of rEFIt (U)EFI Boot Manager - GIT Version"
url="http://www.rodsbooks.com/refind/index.html"
@@ -26,9 +26,11 @@ backup=('boot/efi/efi/arch_refind/refind.conf'
options=('!strip' 'docs')
install="${_pkgname}.install"
-source=('refind_linux.conf')
+source=('refind_include_more_shell_paths.patch'
+ 'refind_linux.conf')
-sha256sums=('9aac6e65018965ba182ec2d246d37fc5f9269ae96504956d8a51355c3ba1b62f')
+sha256sums=('a46ef102eadfd1cf9e43527ed8409d3d9f69e96c8136132b3448c4524ed9ea89'
+ '9aac6e65018965ba182ec2d246d37fc5f9269ae96504956d8a51355c3ba1b62f')
_gitroot="git://git.code.sf.net/p/refind/code"
_gitname="${_actualname}"
@@ -73,8 +75,13 @@ build() {
cp -r "${srcdir}/${_gitname}" "${srcdir}/${_gitname}_build"
cd "${srcdir}/${_gitname}_build"
+ echo
+
+ patch -Np1 -i "${srcdir}/refind_include_more_shell_paths.patch"
+ echo
make
+ echo
}
diff --git a/refind_include_more_shell_paths.patch b/refind_include_more_shell_paths.patch
new file mode 100644
index 000000000000..9863f3cfd206
--- /dev/null
+++ b/refind_include_more_shell_paths.patch
@@ -0,0 +1,19 @@
+diff --git a/refind/main.c b/refind/main.c
+index 6959a05..cb5cf82 100644
+--- a/refind/main.c
++++ b/refind/main.c
+@@ -56,11 +56,11 @@
+
+ #define MACOSX_LOADER_PATH L"\\System\\Library\\CoreServices\\boot.efi"
+ #if defined (EFIX64)
+-#define SHELL_NAMES L"\\EFI\\tools\\shell.efi,\\shellx64.efi"
++#define SHELL_NAMES L"\\EFI\\tools\\shellx64.efi,\\EFI\\tools\\shell.efi,\\shellx64.efi"
+ #elif defined (EFI32)
+-#define SHELL_NAMES L"\\EFI\\tools\\shell.efi,\\shellia32.efi"
++#define SHELL_NAMES L"\\EFI\\tools\\shellia32.efi,\\EFI\\tools\\shell.efi,\\shellia32.efi"
+ #else
+-#define SHELL_NAMES L"\\EFI\\tools\\shell.efi"
++#define SHELL_NAMES L"\\EFI\\tools\\shell.efi,\\shell.efi"
+ #endif
+
+ static REFIT_MENU_ENTRY MenuEntryAbout = { L"About rEFInd", TAG_ABOUT, 1, 0, 'A', NULL, NULL, NULL };