summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-11-14 00:36:21 +0530
committerKeshav Amburay2013-11-14 00:39:51 +0530
commit9011156539aaefa71988c71814825eb4d3bbd035 (patch)
tree40505dbdc191065e0144e67561c1af2a0b3a5363
parentabec53cdb4743f1419323b44e60ad2a4e5364454 (diff)
downloadaur-9011156539aaefa71988c71814825eb4d3bbd035.tar.gz
Enable QEMU Flash support
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--ovmf.install13
3 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cbe2cd164e0..089c71146096 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ovmf-svn
- pkgdesc = UEFI Firmware (OVMF) with Secure Boot Support - for Virtual Machines (QEMU) - from Tianocore EDK2 - SVN Version
- pkgver = 14795
+ pkgdesc = x86_64 UEFI Firmware (OVMF) with Secure Boot Support - for Virtual Machines (QEMU) - from Tianocore EDK2 - SVN Version
+ pkgver = 14844
pkgrel = 1
url = http://sourceforge.net/apps/mediawiki/tianocore/index.php?title=OVMF
install = ovmf.install
diff --git a/PKGBUILD b/PKGBUILD
index bc8647eb5a6f..054e556f7c3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,9 +20,9 @@ _OPENSSL_VERSION="0.9.8w"
_pkgname="ovmf"
pkgname="${_pkgname}-svn"
-pkgver=14795
+pkgver=14844
pkgrel=1
-pkgdesc="UEFI Firmware (OVMF) with Secure Boot Support - for Virtual Machines (QEMU) - from Tianocore EDK2 - SVN Version"
+pkgdesc="x86_64 UEFI Firmware (OVMF) with Secure Boot Support - for Virtual Machines (QEMU) - from Tianocore EDK2 - SVN Version"
url="http://sourceforge.net/apps/mediawiki/tianocore/index.php?title=OVMF"
arch=('x86_64')
license=('BSD')
@@ -198,7 +198,7 @@ build() {
echo
msg "Compile OVMF binary"
- "${_UDK_DIR}/OvmfPkg/build.sh" -a "X64" -b "${_TIANOCORE_TARGET}" -t "${_COMPILER}" -D "SECURE_BOOT_ENABLE=TRUE" -D "BUILD_NEW_SHELL"
+ "${_UDK_DIR}/OvmfPkg/build.sh" -a "X64" -b "${_TIANOCORE_TARGET}" -t "${_COMPILER}" -D "SECURE_BOOT_ENABLE=TRUE" -D "FD_SIZE_2MB" --enable-flash
echo
}
@@ -207,8 +207,8 @@ package() {
_setup_env_vars
- msg "Install the OVMF X64 image as bios.bin for QEMU"
- install -d "${pkgdir}/usr/share/ovmf/x86_64"
- install -D -m0644 "${_UDK_DIR}/Build/${_TIANOCORE_PKG}/${_TIANOCORE_TARGET}_${_COMPILER}/FV/OVMF.fd" "${pkgdir}/usr/share/ovmf/x86_64/bios.bin"
+ msg "Install the OVMF X64 image as ovmf.bin"
+ install -d "${pkgdir}/usr/share/ovmf"
+ install -D -m0644 "${_UDK_DIR}/Build/${_TIANOCORE_PKG}/${_TIANOCORE_TARGET}_${_COMPILER}/FV/OVMF.fd" "${pkgdir}/usr/share/ovmf/x86_64/ovmf.bin"
}
diff --git a/ovmf.install b/ovmf.install
index 8c6ad9e88370..3d98e218eb34 100644
--- a/ovmf.install
+++ b/ovmf.install
@@ -2,9 +2,18 @@ post_install() {
cat << EOF
- To test OVMF X64 in QEMU 1.5 , run :
+ NOTE: The OVMF X64 image has been moved to /usr/share/ovmf/x86_64/ovmf.bin
- qemu-system-x86_64 -enable-kvm -net none -m 1024 -bios /usr/share/ovmf/x86_64/bios.bin
+ OVMF now support NV VAR storage within the OVMF image if QEMU flash (-pflash) is supported
+ This requires write access by QEMU to the OVMF image
+ For more info see http://sourceforge.net/p/tianocore/edk2/ci/e58e5bcd23badac8ef91d3bcc73baac3ca27e2ae/
+
+ To test OVMF X64 in QEMU (use >= v1.5), run:
+
+ \$ cp /usr/share/ovmf/x86_64/ovmf.bin ~/ovmf.bin
+ \$ qemu-system-x86_64 -enable-kvm -net none -m 1024 -pflash ~/ovmf.bin
+
+ NOTE: The command is not -bios , it is -pflash now
EOF