summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2018-08-09 10:16:25 +0200
committeranthraxx2018-08-09 10:16:25 +0200
commitd984dedbbb9aee7faab00f2e5a5f04c98e762482 (patch)
tree9345834d7222637586a9c3691b1eaed9c71a7996
parentcd8f39db4caee047acfde5c9b74aecced74eaab1 (diff)
downloadaur-d984dedbbb9aee7faab00f2e5a5f04c98e762482.tar.gz
upgpkg: owl-lisp-git 0.1.13+569+g64730ee-1 (new upstream url)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0260fc71bc70..9f74e6667746 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = owl-lisp-git
pkgdesc = Simple purely functional lisp
- pkgver = 0.1.13+16+gb0b76d1
+ pkgver = 0.1.13+569+g64730ee
pkgrel = 1
- url = https://github.com/aoh/owl-lisp
- arch = i686
+ url = https://gitlab.com/owl-lisp/owl.git
arch = x86_64
license = MIT
makedepends = git
+ makedepends = pandoc
depends = glibc
provides = owl-lisp
conflicts = owl-lisp
- source = owl-lisp-git::git+https://github.com/aoh/owl-lisp
+ options = !makeflags
+ source = owl-lisp-git::git+https://gitlab.com/owl-lisp/owl
sha512sums = SKIP
pkgname = owl-lisp-git
diff --git a/PKGBUILD b/PKGBUILD
index 284c1cc3a67d..66d1f6983338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
pkgname=owl-lisp-git
-pkgver=0.1.13+16+gb0b76d1
+pkgver=0.1.13+569+g64730ee
pkgrel=1
pkgdesc='Simple purely functional lisp'
-url='https://github.com/aoh/owl-lisp'
-arch=('i686' 'x86_64')
+url='https://gitlab.com/owl-lisp/owl.git'
+arch=('x86_64')
license=('MIT')
depends=('glibc')
-makedepends=('git')
+makedepends=('git' 'pandoc')
provides=('owl-lisp')
conflicts=('owl-lisp')
-source=(${pkgname}::git+https://github.com/aoh/owl-lisp)
+options=('!makeflags')
+source=(${pkgname}::git+https://gitlab.com/owl-lisp/owl)
sha512sums=('SKIP')
pkgver() {
@@ -21,7 +22,11 @@ pkgver() {
prepare() {
cd ${pkgname}
- sed -ri 's|( \$\(CFLAGS\))|\1 $(LDFLAGS)|g' Makefile
+ # support distro CFLAGS and CPPFLAGS
+ sed -e'/export CFLAGS/d' -e '/CFLAGS =/d' \
+ -e 's|$(CFLAGS)|$(CFLAGS) $(CPPFLAGS)|g' -i Makefile
+ # make build reproducible, we compress ourselves
+ sed -e 's|gzip -9|@echo|g' -e 's|\.gz||g' -i Makefile
}
build() {
@@ -33,8 +38,8 @@ package() {
cd ${pkgname}
make DESTDIR="${pkgdir}" install
install -Dm 644 fasl/* -t "${pkgdir}/var/lib/${pkgname}/fasl"
- install -Dm 644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -Dm 644 LICENCE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.md manual.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}
# vim: ts=2 sw=2 et: