summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNowaker2017-07-26 01:29:22 -0500
committerNowaker2017-07-26 01:29:22 -0500
commit8218d383b6220c47802c513677dc97f919ea1808 (patch)
tree91011316f26b40b099e2fd84277065cb33b3c0e0
downloadaur-8218d383b6220c47802c513677dc97f919ea1808.tar.gz
Import owncloud-9.1.3-2 from [community]
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD73
-rw-r--r--apache.example.conf18
-rw-r--r--owncloud-463e2ea-php71-backport.patch22
-rw-r--r--owncloud-9.1.2-dont_warn_about_php_versions.patch89
-rw-r--r--owncloud-b129d5d-php71-backport.patch13
6 files changed, 255 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a4c04c4c397
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = owncloud
+ pkgdesc = A cloud server to store your files centrally on a hardware controlled by you
+ pkgver = 9.1.3
+ pkgrel = 2
+ url = https://owncloud.org/
+ arch = any
+ license = GPL
+ depends = php-gd
+ optdepends = php-apache: to use the Apache web server
+ optdepends = php-sqlite: to use the SQLite database backend
+ optdepends = php-pgsql: to use the PostgreSQL database backend
+ optdepends = php-ldap: LDAP authentication
+ optdepends = php-intl
+ optdepends = php-apcu
+ optdepends = php-xcache
+ optdepends = mariadb: to use the MySQL database backend
+ optdepends = smbclient: to mount SAMBA shares
+ optdepends = php-mcrypt
+ optdepends = ffmpeg: file preview
+ optdepends = libreoffice: file preview
+ conflicts = owncloud-app-gallery
+ replaces = owncloud-app-gallery
+ options = !strip
+ backup = etc/webapps/owncloud/apache.example.conf
+ source = https://download.owncloud.org/community/owncloud-9.1.3.tar.bz2
+ source = https://download.owncloud.org/community/owncloud-9.1.3.tar.bz2.asc
+ source = apache.example.conf
+ source = owncloud-463e2ea-php71-backport.patch
+ source = owncloud-9.1.2-dont_warn_about_php_versions.patch
+ source = owncloud-b129d5d-php71-backport.patch
+ validpgpkeys = E3036906AD9F30807351FAC32D5D5E97F6978A26
+ sha256sums = e0a1eb35fffb61dab5ca41f6d3fdb4ddcc3ec09683cd620b8094846785d4f6e9
+ sha256sums = SKIP
+ sha256sums = 4a2ad4b4ecc6ede355bec9a21cbf8c8c4b9144033bdf0ed3366617bcb4df1144
+ sha256sums = 9a68c60cba0ee12c05467a66b581adad284447f4d22cb56eec55ed8e4ab0a7d6
+ sha256sums = 5821d6b3234967d9cc86c4ccd1778190d2a95930316821455059ab63b417999e
+ sha256sums = 5916b893303a10eaff72f23394ca8fb566af6413460f16d74877ad822f2e8694
+
+pkgname = owncloud
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4f8f23b253f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Antonio Rojas <nqn1976 @ gmail.com>
+# Based on owncloud-git PKGBUILD by Alexander Ovsyannikov
+
+pkgname=owncloud
+pkgver=9.1.3
+pkgrel=2
+pkgdesc="A cloud server to store your files centrally on a hardware controlled by you"
+arch=('any')
+url="https://owncloud.org/"
+license=('GPL')
+depends=('php-gd')
+optdepends=('php-apache: to use the Apache web server'
+ 'php-sqlite: to use the SQLite database backend'
+ 'php-pgsql: to use the PostgreSQL database backend'
+ 'php-ldap: LDAP authentication'
+ 'php-intl'
+ 'php-apcu'
+ 'php-xcache'
+ 'mariadb: to use the MySQL database backend'
+ 'smbclient: to mount SAMBA shares'
+ 'php-mcrypt'
+ 'ffmpeg: file preview'
+ 'libreoffice: file preview')
+conflicts=('owncloud-app-gallery')
+replaces=('owncloud-app-gallery')
+options=('!strip')
+backup=('etc/webapps/owncloud/apache.example.conf')
+validpgpkeys=('E3036906AD9F30807351FAC32D5D5E97F6978A26')
+source=("https://download.owncloud.org/community/owncloud-${pkgver}.tar.bz2"{,.asc}
+ 'apache.example.conf'
+ owncloud-463e2ea-php71-backport.patch
+ owncloud-9.1.2-dont_warn_about_php_versions.patch
+ owncloud-b129d5d-php71-backport.patch)
+sha256sums=('e0a1eb35fffb61dab5ca41f6d3fdb4ddcc3ec09683cd620b8094846785d4f6e9'
+ 'SKIP'
+ '4a2ad4b4ecc6ede355bec9a21cbf8c8c4b9144033bdf0ed3366617bcb4df1144'
+ '9a68c60cba0ee12c05467a66b581adad284447f4d22cb56eec55ed8e4ab0a7d6'
+ '5821d6b3234967d9cc86c4ccd1778190d2a95930316821455059ab63b417999e'
+ '5916b893303a10eaff72f23394ca8fb566af6413460f16d74877ad822f2e8694')
+
+prepare() {
+ cd "$srcdir"/${pkgname}
+ patch -p1 <"$srcdir"/owncloud-463e2ea-php71-backport.patch
+ patch -p1 <"$srcdir"/owncloud-9.1.2-dont_warn_about_php_versions.patch
+ patch -p1 <"$srcdir"/owncloud-b129d5d-php71-backport.patch
+}
+
+package() {
+ # install license
+ install -d "$pkgdir"/usr/share/licenses/${pkgname}
+ cp "$srcdir"/${pkgname}/COPYING-* "$pkgdir"/usr/share/licenses/${pkgname}
+
+ # install project
+ install -d "$pkgdir"/usr/share/webapps/
+ cp -R "$srcdir"/${pkgname} "$pkgdir"/usr/share/webapps/.
+
+ # install apache config file
+ install -d "$pkgdir"/etc/webapps/${pkgname}
+ install -m 644 "$srcdir"/apache.example.conf "$pkgdir"/etc/webapps/${pkgname}
+
+ # move config to /etc
+ install -d "$pkgdir"/etc/webapps/${pkgname}
+ mv "$pkgdir"/usr/share/webapps/${pkgname}/config "$pkgdir"/etc/webapps/${pkgname}/config
+ chown -R http:http "$pkgdir"/etc/webapps/${pkgname}
+ ln -s /etc/webapps/${pkgname}/config "$pkgdir"/usr/share/webapps/${pkgname}/config
+ chown -R root:http "$pkgdir"/usr/share/webapps/${pkgname}
+
+ find "$pkgdir"/usr/share/webapps/${pkgname} -type f -exec chmod 0644 {} \;
+ find "$pkgdir"/usr/share/webapps/${pkgname} -type d -exec chmod 0755 {} \;
+
+ chmod a+x "$pkgdir"/usr/share/webapps/${pkgname}/occ
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..6c6ab87d0d26
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,18 @@
+<IfModule mod_alias.c>
+ Alias /owncloud /usr/share/webapps/owncloud/
+</IfModule>
+
+<Directory /usr/share/webapps/owncloud/>
+ Options FollowSymlinks
+ AllowOverride all
+ Require all granted
+ php_admin_value open_basedir "/srv/http/:/dev/urandom:/tmp/:/usr/share/pear/:/usr/share/webapps/owncloud/:/etc/webapps/owncloud"
+</Directory>
+
+<VirtualHost *:80>
+ ServerAdmin foo@foofarm.com
+ DocumentRoot /usr/share/webapps/owncloud
+ ServerName owncloud.foo.com
+ ErrorLog /var/log/httpd/owncloud.foo.info-error_log
+ CustomLog /var/log/httpd/owncloud.foo.info-access_log common
+</VirtualHost>
diff --git a/owncloud-463e2ea-php71-backport.patch b/owncloud-463e2ea-php71-backport.patch
new file mode 100644
index 000000000000..1a24d7348b44
--- /dev/null
+++ b/owncloud-463e2ea-php71-backport.patch
@@ -0,0 +1,22 @@
+From 463e2ea15d6fb71b96363d60c7e4bdc2c020eddf Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20M=C3=BCller?= <thomas.mueller@tmit.eu>
+Date: Mon, 4 Jul 2016 13:47:03 +0200
+Subject: [PATCH] Initialize array elements properly
+
+---
+ lib/private/App/InfoParser.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/private/App/InfoParser.php b/lib/private/App/InfoParser.php
+index c158e5c..843ed02 100644
+--- a/lib/private/App/InfoParser.php
++++ b/lib/private/App/InfoParser.php
+@@ -141,7 +141,7 @@ function xmlToArray($xml) {
+ $totalElement = count($xml->{$element});
+
+ if (!isset($array[$element])) {
+- $array[$element] = "";
++ $array[$element] = $totalElement > 1 ? [] : "";
+ }
+ /** @var \SimpleXMLElement $node */
+ // Has attributes
diff --git a/owncloud-9.1.2-dont_warn_about_php_versions.patch b/owncloud-9.1.2-dont_warn_about_php_versions.patch
new file mode 100644
index 000000000000..87888184c24c
--- /dev/null
+++ b/owncloud-9.1.2-dont_warn_about_php_versions.patch
@@ -0,0 +1,89 @@
+diff --git a/console.php b/console.php
+index 7235965..1f4b721 100644
+--- a/console.php
++++ b/console.php
+@@ -33,21 +33,6 @@ use Symfony\Component\Console\Output\ConsoleOutput;
+
+ define('OC_CONSOLE', 1);
+
+-// Show warning if a PHP version below 5.4.0 is used, this has to happen here
+-// because base.php will already use 5.4 syntax.
+-if (version_compare(PHP_VERSION, '5.4.0') === -1) {
+- echo 'This version of ownCloud requires at least PHP 5.4.0'.PHP_EOL;
+- echo 'You are currently running ' . PHP_VERSION . '. Please update your PHP version.'.PHP_EOL;
+- return;
+-}
+-
+-// Show warning if PHP 7.1 is used as ownCloud is not compatible with PHP 7.1 until
+-// version 9.2.0.
+-if (version_compare(PHP_VERSION, '7.1.0') !== -1) {
+- echo 'This version of ownCloud is not compatible with PHP 7.1.<br/>';
+- echo 'You are currently running ' . PHP_VERSION . '. Please use at least ownCloud 9.2.0.';
+- return;
+-}
+
+ function exceptionHandler($exception) {
+ echo "An unhandled exception has been thrown:" . PHP_EOL;
+@@ -78,7 +63,7 @@ try {
+ echo "Console has to be executed with the user that owns the file config/config.php" . PHP_EOL;
+ echo "Current user: " . $user['name'] . PHP_EOL;
+ echo "Owner of config.php: " . $configUser['name'] . PHP_EOL;
+- echo "Try adding 'sudo -u " . $configUser['name'] . " ' to the beginning of the command (without the single quotes)" . PHP_EOL;
++ echo "Try adding 'sudo -u " . $configUser['name'] . " ' to the beginning of the command (without the single quotes)" . PHP_EOL;
+ exit(0);
+ }
+ }
+diff --git a/index.php b/index.php
+index 136ddcb..5230cb2 100644
+--- a/index.php
++++ b/index.php
+@@ -24,31 +24,9 @@
+ *
+ */
+
+-// Show warning if a PHP version below 5.4.0 is used, this has to happen here
+-// because base.php will already use 5.4 syntax.
+-if (version_compare(PHP_VERSION, '5.4.0') === -1) {
+- echo 'This version of ownCloud requires at least PHP 5.4.0<br/>';
+- echo 'You are currently running ' . PHP_VERSION . '. Please update your PHP version.';
+- return;
+-}
+-
+-// Show warning if PHP 7.1 is used as ownCloud is not compatible with PHP 7.1 until
+-// version 9.2.0.
+-if (version_compare(PHP_VERSION, '7.1.0') !== -1) {
+- echo 'This version of ownCloud is not compatible with PHP 7.1.<br/>';
+- echo 'You are currently running ' . PHP_VERSION . '. Please use at least ownCloud 9.2.0.';
+- return;
+-}
+-
+-// running oC on Windows is unsupported since 8.1, this has to happen here because
+-// is seems that the autoloader on Windows fails later and just throws an exception.
+-if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
+- echo 'ownCloud Server does not support Microsoft Windows.';
+- return;
+-}
+
+ try {
+-
++
+ require_once 'lib/base.php';
+
+ OC::handleRequest();
+diff --git a/settings/Controller/CheckSetupController.php b/settings/Controller/CheckSetupController.php
+index 52ef34d..e39fdf2 100644
+--- a/settings/Controller/CheckSetupController.php
++++ b/settings/Controller/CheckSetupController.php
+@@ -349,11 +349,7 @@ Raw output
+ protected function isEndOfLive() {
+ $eol = false;
+
+- //PHP 5.4 is EOL on 14 Sep 2015
+- if (version_compare(PHP_VERSION, '5.5.0') === -1) {
+- $eol = true;
+- return $eol;
+- }
++ // Red Hat support PHP so don't EOL
+ return $eol;
+ }
+ }
diff --git a/owncloud-b129d5d-php71-backport.patch b/owncloud-b129d5d-php71-backport.patch
new file mode 100644
index 000000000000..734b51cc76b2
--- /dev/null
+++ b/owncloud-b129d5d-php71-backport.patch
@@ -0,0 +1,13 @@
+diff --git a/settings/Controller/SecuritySettingsController.php b/settings/Controller/SecuritySettingsController.php
+index 88b2803..5c6f174 100644
+--- a/settings/Controller/SecuritySettingsController.php
++++ b/settings/Controller/SecuritySettingsController.php
+@@ -60,7 +60,7 @@ protected function returnSuccess() {
+ * @return array
+ */
+ public function trustedDomains($newTrustedDomain) {
+- $trustedDomains = $this->config->getSystemValue('trusted_domains');
++ $trustedDomains = $this->config->getSystemValue('trusted_domains', []);
+ $trustedDomains[] = $newTrustedDomain;
+ $this->config->setSystemValue('trusted_domains', $trustedDomains);
+