summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-06-01 09:45:38 +0100
committerGrey Christoforo2016-06-01 09:45:38 +0100
commit82b5f8f44340465d63bf0450ae402d9915d32bcb (patch)
tree8fe204633143ae7f2c93510cf508f4f491df6399
parentc8da1e381a2099ec066f8deba614eaded22c9ca5 (diff)
downloadaur-82b5f8f44340465d63bf0450ae402d9915d32bcb.tar.gz
fix up permissions
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xset-oc-perms.sh11
3 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 530c4be46221..ed9609669cf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 10 18:13:36 UTC 2016
+# Wed Jun 1 08:45:34 UTC 2016
pkgbase = owncloud-archive
pkgdesc = ownCloud server release, installed from the official .tar.bz2 archive
pkgver = 9.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://owncloud.org
install = owncloud-archive.install
arch = any
@@ -34,7 +34,7 @@ pkgbase = owncloud-archive
md5sums = a0131f5cae2b1503b8de6796487c1bdc
md5sums = SKIP
md5sums = bf523e475fd8cf1e2048018952da5c34
- md5sums = 30333bf6beb39b5048fcb85c74e690c0
+ md5sums = 1ca5504c1b32fbbbe7b1710db6779744
pkgname = owncloud-archive
diff --git a/PKGBUILD b/PKGBUILD
index eebfa9dd00a2..03861ce68e44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=owncloud-archive
pkgver=9.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="ownCloud server release, installed from the official .tar.bz2 archive"
url="https://owncloud.org"
arch=('any')
@@ -32,7 +32,7 @@ source=("https://download.owncloud.org/community/owncloud-${pkgver}.tar.bz2"{,.a
md5sums=('a0131f5cae2b1503b8de6796487c1bdc'
'SKIP'
'bf523e475fd8cf1e2048018952da5c34'
- '30333bf6beb39b5048fcb85c74e690c0')
+ '1ca5504c1b32fbbbe7b1710db6779744')
options=(!strip emptydirs)
diff --git a/set-oc-perms.sh b/set-oc-perms.sh
index 30ab966e1472..c7507812f69e 100755
--- a/set-oc-perms.sh
+++ b/set-oc-perms.sh
@@ -32,14 +32,21 @@ runtime() {
printf "chmod/chown .htaccess\n"
if [ -f ${ocpath}/.htaccess ]
then
- chmod 0644 ${ocpath}/.htaccess
+ chmod 0664 ${ocpath}/.htaccess
chown ${rootuser}:${htgroup} ${ocpath}/.htaccess
fi
if [ -f ${ocpath}/data/.htaccess ]
then
- chmod 0644 ${ocpath}/data/.htaccess
+ chmod 0664 ${ocpath}/data/.htaccess
chown ${rootuser}:${htgroup} ${ocpath}/data/.htaccess
fi
+
+ printf "chmod/chown .user.ini\n"
+ if [ -f ${ocpath}/.user.ini ]
+ then
+ chmod 0664 ${ocpath}/.user.ini
+ chown ${rootuser}:${htgroup} ${ocpath}/.htaccess
+ fi
}
upgrade() {