summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-03-14 20:06:09 +0000
committerGrey Christoforo2016-03-14 20:06:09 +0000
commitc13ca0544608bb59e40154fd5ace462740e4ecd5 (patch)
treeacd88b8533a54d2f326c084e1332c9efc8301ead
downloadaur-c13ca0544608bb59e40154fd5ace462740e4ecd5.tar.gz
initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD48
-rw-r--r--apache.example.conf14
-rw-r--r--owncloud-archive.install47
5 files changed, 154 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d85bdf1ce9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+# Generated by mksrcinfo v8
+# Mon Mar 14 20:06:01 UTC 2016
+pkgbase = owncloud-archive
+ pkgdesc = ownCloud server release, installed from the official .tar.bz2 archive
+ pkgver = 9.0.0
+ pkgrel = 1
+ url = https://owncloud.org
+ install = owncloud-archive.install
+ arch = any
+ license = GPL
+ depends = php
+ depends = php-gd
+ optdepends = php-apache: to use the Apache web server
+ optdepends = php-sqlite: to use the SQLite database backend
+ optdepends = php-pgsql: to use the PostgreSQL database backend
+ optdepends = php-ldap: LDAP authentication
+ optdepends = php-intl
+ optdepends = php-apcu
+ optdepends = php-xcache
+ optdepends = mariadb: to use the MySQL database backend
+ optdepends = smbclient: to mount SAMBA shares
+ optdepends = php-mcrypt
+ optdepends = imagemagick: file preview
+ optdepends = ffmpeg: file preview
+ optdepends = libreoffice: file preview
+ provides = owncloud
+ conflicts = owncloud
+ options = !strip
+ options = emptydirs
+ backup = etc/webapps/owncloud/apache.example.conf
+ source = https://download.owncloud.org/community/owncloud-9.0.0.tar.bz2
+ source = https://download.owncloud.org/community/owncloud-9.0.0.tar.bz2.asc
+ source = apache.example.conf
+ md5sums = 1f14d7f2faa0ba704901e062301854db
+ md5sums = SKIP
+ md5sums = e392cbbb21e674a605c3ff7f23852bfa
+
+pkgname = owncloud-archive
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a144999fcb82
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.bz2
+*.asc
+*.pkg.tar.xz
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b648e5dfe98c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=owncloud-archive
+pkgver=9.0.0
+pkgrel=1
+pkgdesc="ownCloud server release, installed from the official .tar.bz2 archive"
+url="https://owncloud.org"
+arch=('any')
+license=('GPL')
+conflicts=('owncloud')
+provides=('owncloud')
+depends=('php' 'php-gd')
+optdepends=('php-apache: to use the Apache web server'
+ 'php-sqlite: to use the SQLite database backend'
+ 'php-pgsql: to use the PostgreSQL database backend'
+ 'php-ldap: LDAP authentication'
+ 'php-intl'
+ 'php-apcu'
+ 'php-xcache'
+ 'mariadb: to use the MySQL database backend'
+ 'smbclient: to mount SAMBA shares'
+ 'php-mcrypt'
+ 'imagemagick: file preview'
+ 'ffmpeg: file preview'
+ 'libreoffice: file preview')
+options=('!strip')
+backup=('etc/webapps/owncloud/apache.example.conf')
+install=${pkgname}.install
+validpgpkeys=('E3036906AD9F30807351FAC32D5D5E97F6978A26')
+source=("https://download.owncloud.org/community/owncloud-${pkgver}.tar.bz2"{,.asc} "apache.example.conf")
+md5sums=('1f14d7f2faa0ba704901e062301854db'
+ 'SKIP'
+ 'e392cbbb21e674a605c3ff7f23852bfa')
+
+options=(!strip emptydirs)
+
+package() {
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ cp ${srcdir}/owncloud/COPYING-* ${pkgdir}/usr/share/licenses/${pkgname}
+
+ mkdir -p "${pkgdir}/usr/share/webapps"
+ cp -a owncloud "${pkgdir}/usr/share/webapps/."
+
+ install -m644 -D ${srcdir}/apache.example.conf -t ${pkgdir}/etc/webapps/owncloud
+ install -m755 -D ${srcdir}/owncloud/occ -t ${pkgdir}/usr/bin
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..6ae56a3ee150
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,14 @@
+Alias /owncloud "/usr/share/webapps/owncloud"
+
+<Directory /usr/share/webapps/owncloud/>
+ Options +FollowSymlinks
+ AllowOverride All
+
+ <IfModule mod_dav.c>
+ Dav off
+ </IfModule>
+
+ SetEnv HOME /usr/share/webapps/owncloud
+ SetEnv HTTP_HOME /usr/share/webapps/owncloud
+
+</Directory>
diff --git a/owncloud-archive.install b/owncloud-archive.install
new file mode 100644
index 000000000000..0dedf944f5f5
--- /dev/null
+++ b/owncloud-archive.install
@@ -0,0 +1,47 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+ocpath='/usr/share/webapps/owncloud'
+htuser='http'
+htgroup='http'
+rootuser='root'
+
+fix_perms () {
+ printf "Creating possible missing Directories\n"
+ mkdir -p $ocpath/data
+ mkdir -p $ocpath/assets
+
+ printf "chmod Files and Directories\n"
+ find ${ocpath}/ -type f -print0 | xargs -0 chmod 0640
+ find ${ocpath}/ -type d -print0 | xargs -0 chmod 0750
+
+ printf "chown Directories\n"
+ chown -R ${rootuser}:${htgroup} ${ocpath}/
+ chown -R ${htuser}:${htgroup} ${ocpath}/apps/
+ chown -R ${htuser}:${htgroup} ${ocpath}/config/
+ chown -R ${htuser}:${htgroup} ${ocpath}/data/
+ chown -R ${htuser}:${htgroup} ${ocpath}/themes/
+ chown -R ${htuser}:${htgroup} ${ocpath}/assets/
+
+ chmod +x ${ocpath}/occ
+
+ printf "chmod/chown .htaccess\n"
+ if [ -f ${ocpath}/.htaccess ]
+ then
+ chmod 0644 ${ocpath}/.htaccess
+ chown ${rootuser}:${htgroup} ${ocpath}/.htaccess
+ fi
+ if [ -f ${ocpath}/data/.htaccess ]
+ then
+ chmod 0644 ${ocpath}/data/.htaccess
+ chown ${rootuser}:${htgroup} ${ocpath}/data/.htaccess
+ fi
+}
+
+post_install () {
+ fix_perms
+}
+
+post_upgrade() {
+ fix_perms
+}