summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Kuehn2015-08-31 20:59:56 +0200
committerDanilo Kuehn2015-08-31 20:59:56 +0200
commit48d5d81b021f5ac84d0a2fd1bf83929382991523 (patch)
tree8232b1425a2a02ffaaec8d07dcc0c6964a611121
parent7cd44c5126951ff4ecb706ff1dcd286579cae009 (diff)
downloadaur-48d5d81b021f5ac84d0a2fd1bf83929382991523.tar.gz
Update to v2.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc7fcf77d70c..9b4e1a02d689 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = owncloud-client-git
pkgdesc = ownCloud client based on mirall
- pkgver = 1.8.3
+ pkgver = 2.0.0
pkgrel = 1
url = http://owncloud.org/
install = owncloud-client-git.install
@@ -10,8 +10,8 @@ pkgbase = owncloud-client-git
makedepends = cmake
depends = sqlite3
depends = neon
- depends = qtkeychain
- depends = qtwebkit
+ depends = qt5-base
+ depends = qtkeychain-qt5
provides = mirall
provides = mirall-git
provides = owncloud-client
@@ -19,8 +19,8 @@ pkgbase = owncloud-client-git
conflicts = owncloud-client
conflicts = owncloud-client-ngs
options = !strip
- backup = etc/owncloud-client-git/sync-exclude.lst
- source = mirall::git+https://github.com/owncloud/mirall.git
+ backup = etc/ownCloud/sync-exclude.lst
+ source = client::git+https://github.com/owncloud/client.git
md5sums = SKIP
pkgname = owncloud-client-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9a17525e0cf8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+client/
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 7f15334189c0..0d2da4ccb33d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,27 @@
# Git: https://github.com/nogo/archlinux-pkgbuild
# Uncomment, if you want tha last release
-_version=1.8.3
+_version=2.0.0
pkgname=owncloud-client-git
-pkgver=1.8.3
+pkgver=2.0.0
pkgrel=1
pkgdesc="ownCloud client based on mirall"
arch=('i686' 'x86_64')
url="http://owncloud.org/"
license=('GPL2')
-depends=('sqlite3' 'neon' 'qtkeychain' 'qtwebkit')
+depends=('sqlite3' 'neon' 'qt5-base' 'qtkeychain-qt5')
optdepends=()
makedepends=('cmake')
provides=('mirall' 'mirall-git' 'owncloud-client')
conflicts=('mirall-git' 'owncloud-client' 'owncloud-client-ngs')
install=${pkgname}.install
options=(!strip)
-backup=('etc/owncloud-client-git/sync-exclude.lst')
-_client=mirall
-source=("${_client}::git+https://github.com/owncloud/mirall.git")
+backup=('etc/ownCloud/sync-exclude.lst')
+_client=client
+source=("${_client}::git+https://github.com/owncloud/client.git")
+#_client=mirall
+#source=("${_client}::git+https://github.com/owncloud/mirall.git")
md5sums=('SKIP')
pkgver() {
@@ -36,16 +38,16 @@ prepare() {
if [[ -n "${_version}" ]]; then
cd ${srcdir}/${_client}
git checkout "v${_version}"
+ git submodule update --init
fi
}
build() {
cd ${srcdir}/${_client}
- cmake -DBUILD_WITH_QT4=on \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname} \
-DWITH_DOC=FALSE \
-DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain/ \