summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManoel Brunnen2016-09-27 08:50:46 +0200
committerManoel Brunnen2016-09-27 08:50:46 +0200
commitd0bf9381aad96201266f4e8d3eeee4b4fb565000 (patch)
tree50a5961bb1cff35b623cb80e404173a8e9d73996
downloadaur-d0bf9381aad96201266f4e8d3eeee4b4fb565000.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
-rw-r--r--owncloud-client-service.install16
-rw-r--r--owncloud-client.service13
5 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1c24fca94b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = owncloud-client-service
+ pkgdesc = Systemd service file for the owncloud client
+ pkgver = 1.0
+ pkgrel = 0
+ install = owncloud-client-service.install
+ arch = any
+ license = MIT
+ depends = owncloud-client
+ source = owncloud-client.service
+ md5sums = 16f131ea71561ef0cd80271884c3ebca
+
+pkgname = owncloud-client-service
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ee2c906bbbe6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+*.tar.*
+*.orig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb5410fcc402
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Manoel Brunnen <manoel.brunnen@gmail.com>
+pkgname=owncloud-client-service
+pkgver=1.0
+pkgrel=0
+pkgdesc='Systemd service file for the owncloud client'
+arch=('any')
+license=(MIT)
+groups=()
+depends=('owncloud-client')
+install="$pkgname.install"
+source=('owncloud-client.service')
+md5sums=('16f131ea71561ef0cd80271884c3ebca')
+
+package() {
+ install -Dm644 $srcdir/owncloud-client.service $pkgdir/usr/lib/systemd/user/owncloud-client.service
+}
+
diff --git a/owncloud-client-service.install b/owncloud-client-service.install
new file mode 100644
index 000000000000..cebf399ac57f
--- /dev/null
+++ b/owncloud-client-service.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo ================================== Important =================================
+ echo Start the owcloud client daemon with:
+ echo systemctl start --user owncloud-client.service
+ echo ==============================================================================
+ echo Enable the owcloud client daemon with:
+ echo systemctl enable --user owncloud-client.service
+ echo ==============================================================================
+}
+post_remove() {
+ echo ================================== Important =================================
+ echo Disable the owcloud client daemon with:
+ echo systemctl disable --user owncloud-client.service
+ echo ==============================================================================
+#}
+# vim:set ts=2 sw=2 ft=sh et:
diff --git a/owncloud-client.service b/owncloud-client.service
new file mode 100644
index 000000000000..a8f3766b41a0
--- /dev/null
+++ b/owncloud-client.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Owncloud Client
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/owncloud
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=on-failure
+
+[Install]
+WantedBy=default.target
+