summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Klomp2018-06-15 22:37:58 +0200
committerSven Klomp2018-06-15 22:37:58 +0200
commit58315550c5b4a3f07fc46327a14ff52e7a536ea8 (patch)
tree99eaf604e4fc6c63b32694efb2927328779d2ebe
parent04fcedc0930a1ee92a1dd139f253bda98dc50d25 (diff)
downloadaur-58315550c5b4a3f07fc46327a14ff52e7a536ea8.tar.gz
Update to version 0.7.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--truncation_error.patch11
3 files changed, 24 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39e9c31f72b4..f0b3a80a4051 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Feb 25 11:07:56 UTC 2018
+# Fri Jun 15 20:37:42 UTC 2018
pkgbase = owntracks-recorder
pkgdesc = Lightweight program for storing and accessing location data published via MQTT (or HTTP) by the OwnTracks apps.
- pkgver = 0.7.5
+ pkgver = 0.7.6
pkgrel = 1
url = https://github.com/owntracks/recorder
arch = i686
@@ -15,8 +15,10 @@ pkgbase = owntracks-recorder
depends = mosquitto
depends = curl
backup = etc/default/ot-recorder
- source = https://github.com/owntracks/recorder/archive/0.7.5.tar.gz
- sha256sums = 9c3ca9ed8cb91290b872f386d710a8f7ab68c1a7a75962896570ba3693dca239
+ source = https://github.com/owntracks/recorder/archive/0.7.6.tar.gz
+ source = truncation_error.patch
+ sha256sums = 94caae03ebaa3bd09ce7c48c0d4a0449d6801ad1e4cd484f519e967b07c0c388
+ sha256sums = e5bdc4a566c6bf86f2a40cfdcc6f0688ca71edd79fd191d17c4ac0c50970e142
pkgname = owntracks-recorder
diff --git a/PKGBUILD b/PKGBUILD
index 27ea299061e5..d54b4fe2c718 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,22 @@
pkgdesc='Lightweight program for storing and accessing location data published via MQTT (or HTTP) by the OwnTracks apps.'
pkgname=('owntracks-recorder')
-pkgver=0.7.5
+pkgver=0.7.6
pkgrel=1
arch=('i686' 'x86_64')
license=('GPL')
url="https://github.com/owntracks/recorder"
makedepends=('libconfig' 'mosquitto' 'curl')
depends=('libconfig' 'mosquitto' 'curl')
-source=("https://github.com/owntracks/recorder/archive/${pkgver}.tar.gz")
-sha256sums=('9c3ca9ed8cb91290b872f386d710a8f7ab68c1a7a75962896570ba3693dca239')
+source=("https://github.com/owntracks/recorder/archive/${pkgver}.tar.gz" "truncation_error.patch")
+sha256sums=('94caae03ebaa3bd09ce7c48c0d4a0449d6801ad1e4cd484f519e967b07c0c388'
+ 'e5bdc4a566c6bf86f2a40cfdcc6f0688ca71edd79fd191d17c4ac0c50970e142')
backup=(etc/default/ot-recorder)
prepare() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/recorder-${pkgver}"
+ patch -Np2 -i "${srcdir}/truncation_error.patch"
}
build() {
@@ -36,7 +38,7 @@ package() {
mkdir -p "${pkgdir}/usr/share/webapps/ot-recorder"
cd "${srcdir}/recorder-${pkgver}"
- make DESTDIR="${pkgdir}/" install
+ make DESTDIR="${pkgdir}/" install -Wno-format-truncation
mv "${pkgdir}/usr/sbin/ot-recorder" "${pkgdir}/usr/bin"
rm -r "${pkgdir}/usr/sbin/"
}
diff --git a/truncation_error.patch b/truncation_error.patch
new file mode 100644
index 000000000000..d4b657fb672e
--- /dev/null
+++ b/truncation_error.patch
@@ -0,0 +1,11 @@
+diff -ura src/recorder-0.7.6/Makefile src/recorder-0.7.6-patched/Makefile
+--- src/recorder-0.7.6/Makefile 2018-06-15 22:14:23.718857468 +0200
++++ src/recorder-0.7.6-patched/Makefile 2018-06-15 22:16:21.138862486 +0200
+@@ -1,6 +1,6 @@
+ include config.mk
+
+-CFLAGS +=-Wall -Werror
++CFLAGS +=-Wall -Werror -Wno-format-truncation
+ LIBS = $(MORELIBS) -lm
+ LIBS += -lcurl -lconfig
+