summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:11:35 -0600
committernot_anonymous2015-07-05 18:11:35 -0600
commit19d9c566a7477608e1dde5b9a6e2e83f0d8073e6 (patch)
treef1fd4a39edf099f4cee5ab857102a997debf48d4
downloadaur-19d9c566a7477608e1dde5b9a6e2e83f0d8073e6.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD55
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19f081d99809
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = owx
+ pkgdesc = A CLI tool for programming KG669V (Wouxun) HTs.
+ pkgver = r17
+ pkgrel = 1
+ url = http://owx.chmurka.net
+ arch = i686
+ arch = x86_64
+ license = Apache
+ license = custom:beerware
+ makedepends = subversion
+ depends = gcc-libs
+ replaces = wouxun
+ source = owx-svn::svn+http://svn.chmurka.net/owx/trunk
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 04c8deadd6984048760870d0fb397f25
+
+pkgname = owx
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ccdeb6d8ccc9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,8 @@
+Code is licensed on beerware license. You are encouraged to experiment and do
+anything you want as long as you keep README intact when distributing and if
+you feel that this code has been useful for you, you can send us some beer.
+
+Authors
+
+SP5GOF gof (at) chmurka.net - coding
+SQ5LWN baseciq (at) baseciq.org - reverse-enginnering and procotol information
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a911feeabb47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# Contributor: Ruslan Nabioullin <rnabioullin@gmail.com>
+# Contributor: Vitaliy Berdinskikh, aka UR6LAD <ur6lad@archlinux.org.ua>
+
+pkgname=owx
+pkgver=r17
+pkgrel=1
+pkgdesc="A CLI tool for programming KG669V (Wouxun) HTs."
+arch=('i686' 'x86_64')
+url="http://owx.chmurka.net"
+license=('Apache' 'custom:beerware')
+depends=('gcc-libs')
+makedepends=('subversion')
+replaces=('wouxun')
+source=("$pkgname-svn::svn+http://svn.chmurka.net/$pkgname/trunk"
+ LICENSE)
+md5sums=('SKIP'
+ '04c8deadd6984048760870d0fb397f25')
+
+pkgver() {
+ cd "$srcdir/$pkgname-svn/$pkgname"
+ printf "r%s" "$(svnversion | tr -d 'A-z')"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname-svn/$pkgname"
+ sed -i -e s:SVN:${pkgver}: src/version.h
+ sed -i -e s:' help':' README': src/cmds.cc
+}
+
+build() {
+ cd "$srcdir/$pkgname-svn/$pkgname"
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/{bin,lib/$pkgname}
+ mkdir -p $pkgdir/usr/share/{doc/$pkgname,licenses/$pkgname}
+
+ cd $srcdir
+ install -m 644 LICENSE $pkgdir/usr/share/licenses/$pkgname
+
+ cd "$srcdir/$pkgname-svn/$pkgname/docs"
+ install -m 644 * $pkgdir/usr/share/doc/$pkgname
+ rm $pkgdir/usr/share/doc/$pkgname/LICENSE
+
+ cd ../src
+ install -D -m 755 $pkgname $pkgdir/usr/lib/$pkgname/$pkgname
+ ln -sf ../lib/$pkgname/$pkgname $pkgdir/usr/bin/$pkgname-check
+ ln -sf ../lib/$pkgname/$pkgname $pkgdir/usr/bin/$pkgname-get
+ ln -sf ../lib/$pkgname/$pkgname $pkgdir/usr/bin/$pkgname-put
+ ln -sf ../lib/$pkgname/$pkgname $pkgdir/usr/bin/$pkgname-export
+ ln -sf ../lib/$pkgname/$pkgname $pkgdir/usr/bin/$pkgname-import
+ ln -sf ../lib/$pkgname/$pkgname $pkgdir/usr/bin/$pkgname-fsk
+}